
EngineerIT

Control Builder F

Engineering Manual
Freelance 2000 Operator Station Configuration



Notice

Information provided in this manual is subject to change without prior notice and
represents no obligation on the part of ABB Automation Products.

The industrial standards and regulations (e.g. DIN, VDE, VDI, etc.) applicable in the
Federal Republic of Germany are used. Outside the Federal Republic of Germany, the
relevant national specifications, standards and regulations must be observed.

ABB Automation Products reserves all rights, especially those arising out of BGB,
UWG, UrhG as well as out of industrial property rights (patents, utility models,
trademarks, service trademarks and flavor samples).

The designations used and the products shown/mentioned in this manual have not been
specifically marked regarding existing industrial property rights.

No part of this manual may be reproduced without prior written permission from ABB
Automation Products.

Should you find any mistakes in this manual, please make a copy of the appropriate
page(s) and send it/them to us with your comments. Any suggestions which may help to
improve comprehension or clarity will also be gratefully accepted.

Please send your suggestions to:

Product Management Dept., DEAPR/LMS-Hannover, Fax: +49 (0)511 6782 701

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Engineering Manual
Operator Station

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Overview

Engineering Manuals

System Configuration
A General Information
B Installation DigiTool
C Project Manager
D Project Tree
E Hardware Structure
F Commissioning
G Documentation

Glossary
New Features
Index

IEC 61131-3 Programming
A General Information
B Variables
C Tags
D Function Block Diagram (FBD)
E Instruction List (IL)
F Ladder Diagram (LD)
G Sequential Function Chart (SFC)
H User Function Blocks

Index

Operator Station
A General Information
B Messages and Hints
C Standard Displays
D Graphic Display
E Logs

Index

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Overview

Engineering Manuals

Process Station – Rack based System
1 General
2 Loading the operating system and EPROM’S
3 Configuration of resource D-PS and D-PS/RED in project tree
4 Processing and failure action
5 Configuration of rack-based process station in the hardware structure
6 Commissioning the process station
7 Redundancy

Process Station –FieldController
1 General
2 Loading the operating system and EPROM’S
3 Configuration of resource D-PS in project tree
4 Processing and failure action
5 Configuration of process station FC in the hardware structure
6 Commissioning of FC

Process Station – ABB FieldController 800
1 General
2 Loading the operating system and EPROM’S
3 Configuration of resource D-PS and D-PS/RED in project tree
4 Processing and failure action
5 Configuration of process station AC 800F in the hardware structure
6 Commissioning of AC 800F
7 Redundancy

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Overview

Engineering Reference Manuals

Functions and Function Blocks
A Getting Started
B General Description and Overview
C Analog Function Blocks
D Binary Function Blocks
E Controller Function Blocks
F Acquisition Blocks
G Monitoring Function Blocks
H Open-loop Control Function Blocks
J Standard Function Blocks
K Arithmetic Blocks
L Converter Blocks
M Constants
N System Functions
V Abbreviations
W Glossary
X Index

Communications and Fieldbusses
A Getting Started
B General Description and Overview
C Profibus
E Modbus Master Function Blocks
F Modbus Slave Function Blocks
G Send / Receive Blocks
H Rack Modules
V Abbreviations
W Glossary
X Index

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Overview

Operators Manual

Operator Station
A Getting started: DigiVis
B Installation DigiVis
C Operating Philosophy
D Messages and Hints
E Overview Display
F Group Display
G Graphic Display
H Trend Display
I Faceplates
J SFC Display
K Time Scheduler Display
L Logs
M System Display
V System Messages
W Glossary
X Index

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Contents

Contents

A General Information

A  1 Visual Orientation Hints ..........................................................................................A-5
A  2 General Hints for Operating DigiTool .....................................................................A-6

B Messages and Hints

B  1 General Description - Messages and Hints ............................................................B-5
B  2 Types of Messages.................................................................................................B-9
B  3 Acoustic Messages, Field Horn and Control Room Horn .....................................B-14
B  4 Global Message Processing .................................................................................B-18
B  5 Local Message Processing...................................................................................B-19

C Standard Displays

C  1 Display Access .......................................................................................................C-5
C  2 Overview Display ....................................................................................................C-8
C  3 Group Display .......................................................................................................C-11
C  4 Trend Display........................................................................................................C-14
C  5 Sequential Function Chart Display .......................................................................C-26
C  6 Time Scheduler Display........................................................................................C-28

D Graphic Display

D  1 General Description - Graphic Display ...................................................................D-5
D  2 Graphic Editor Interface..........................................................................................D-6
D  3 Basic Settings for the Draw Area..........................................................................D-11
D  4 Drawing Static Graphic Objects............................................................................D-15
D  5 Animate, Dynamic Graphic Objects......................................................................D-24
D  6 Macro ....................................................................................................................D-68
D  7 Editing and Changing Display Objects .................................................................D-75
D  2 Display Options for Graphics in the Draw Area ....................................................D-90
D  3 General Processing Functions..............................................................................D-93
D  4 Appendix - Color Tables .......................................................................................D-98
D  5 Appendix - Graphic Macro Library ......................................................................D-101

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Contents

E Logs

E  1 General Description - Logs .....................................................................................E-5
E  2 Signal Sequence Log Configuration .......................................................................E-7
E  3 Disturbance Course Log Configuration.................................................................E-16
E  4 Operation Log Configuration.................................................................................E-21
E  5 Header and Footer Lines in Logs..........................................................................E-27

X Index

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



A General Information

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section A General Information

A-3

Contents

A 1 Visual Orientation Hints........................................................................................ A-5

A 2 General Hints for Operating DigiTool.................................................................. A-6
A 2.1 Operation with mouse or keyboard ......................................................................... A-6
A 2.2 Recurring keys ........................................................................................................ A-7

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section A General Information

A-5

A 1 Visual Orientation Hints

To grant direct access to information, we have used different types of scripts and symbols.

Script Meaning

Italics Representation for (selectable) menu items or parameters.

SMALL CAPITALS Inputs to be made via the keyboard, also via virtual keys.

boldface Highlights important information, also as an orientation hint.

Symbols Meaning

Selection with mouse.
The various instruction steps are separated by arrows.
Example: → Edit → Dimensions → ... .
In this example, the menu item Edit is to be selected followed by the
menu item Dimensions.

Operating alternative with the mouse

Information on operation with the keyboard, inasmuch as it differs from
the Windows Standard.
Example: Select module → ALT → E → D → ... .
Having selected the module via the ARROW KEYS, the keys ALT, E and D

must be pressed successively.

If two keys are to be pressed simultaneously:
... → SHIFT + INSERT → ... .

Alternative keyboard operation

Hints

Special hints, must be observed!

Preconditions Preconditions which must be fulfilled to implement commands or for
satisfactory results.
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A 2 General Hints for Operating DigiTool

Operation of DigiTool is based on the Windows Standard.
Therefore knowledge of general operation under Windows is strongly recommended, see
Windows Manual.

The "typical Windows operation" will therefore not be dealt with in detail when describing the
various editors.

A 2.1 Operation with mouse or keyboard

Mouse Keyboard

Select menu
items

Cursor on menu item
+ left mouse button.

ALT + underlined letters

Select within
pull-down menu

Cursor on menu item
+ left mouse button.

Enter only underline letters

Select individual
elements

Cursor on program element
+ left mouse button

Cursor on program element
+ SPACE

Select multiple
elements

Cursor on start position
→ press left mouse button and

keep pressed down
→ move to desired position and

release mouse button

Cursor on start position
→ Press SPACE and hold

→ move to desired position and
release SPACE
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A 2.2 Recurring keys

OK The active parameter window is quit and the parameter status saved.

CANCEL The active parameter window is quit without saving the parameter
status. A warning appears if parameter definition data are lost.

SAVE The current parameter status is saved and the window remains active.

RESET The parameters of the active parameter window are reset completely to
the previously set values. Any parameters previously saved and differing
from the default settings can be fetched again by canceling and recalling
the parameter window.

CHECK The function block is checked for plausibility with the current parameters,
even if they have not been saved.

HELP Call up the Windows On-line help (with F1 also).
To get information about functions on monitor without using the docu-
mentation. Thematically structured information is displayed in the help-
window.

di0212uk.bmp

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section A General Information

A-8

<< Change to the previous
>> or next parameter mask.

This is displayed with shading if no further parameter window exist.

Check boxes
A setting or parameter is turned on or off.

Option fields
Option fields are presented when one of a group of mutually
parameters are to be chosen.

F5 The function key F5 calls the list of cross references for the selected vari-
able or tag. This function is also available in parameter mask fields with
referenced variables or tags.

F6 bzw. SHIFT+F6 These functions are available after the list of all existing cross references
was called (key F5). F6 calls the program which contains the next occur-
rence in the cross reference list, SHIFT+F6 calls the program of the previ-
ous list entry.
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B 1 General Description - Messages and Hints

The task of message processing in DigiTool is to configure the method of processing and
displaying messages in DigiVis.

Messages are used by the process stations and other types of station in the Freelance 2000
system to notify the operator stations of changes in the process operation. Such changes may be
faults or states in the process or also error functions of the Freelance 2000 system itself.

The Freelance 2000 system makes available the message types system message, fault
message, switch message, hint and hint message. These types of message can be classified
into different priority levels, one system level (divided into three groups, S1 - S3) and five user
levels (1 - 5). The individual priority levels are displayed in different colors.

Different acknowledgment strategies can be allocated to these priority levels.
Acknowledgment strategy here means how the operator at the control stations is to acknowledge
the messages which arrive. The acknowledgment strategy to be used for each priority can also
be configured.

Configuration is divided into global and local message processing.
Global message processing comprises configuration of the acknowledgment strategies of
messages in the Freelance 2000 system as a whole.

Local message processing comprises configuration of the station-specific settings for message
list, message line, hint list and horn activation. It has to be done for each operator station
separately.
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B 1.1 Display of the message line during operation

The message line is always visible in DigiVis. Thus the operator at the operator station can
immediately ascertain incorrect behavior in the process and take appropriate action.
The message line contains fields for the display of messages and buttons for acknowledging
messages in the message line and for selecting items on the hint list. It also contains a field for
displaying an overflow of the message line and the number of all messages contained in the
message list.

Depending on the configuration of the type of acknowledgment, the display of the mes-
sage line changes. For visual acknowledgment the VA button is displayed on the right
and for normal acknowledgment the A button is displayed.

FREELANCE This button is active if messages arrive for which hints are configured.
This also applies to the arrival of special hint messages. The hint list can
then be displayed.

Message fields Messages which arrive are displayed in these fields. A maximum of five
messages can be displayed in the message line.
The display in the message field contains two lines. The first line contains
the tag name of the loop, and the second line the configured message
text.

>> This field is designated the overflow field. The area has a yellow back-
ground if there are more messages than can be displayed in the message
line. The number below this indicates the total number of messages.

VA The displayed messages are acknowledged. This is a visual acknowl-
edgment only; the number of messages is not affected by this.

A The displayed messages are acknowledged normally. The number of
messages is updated if necessary.

When a message is selected in the message line, the appropriate
faceplate is called up for operation.

HORN Switch off the field and/or control room horn.

vd0210us.bmp
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B 1.2 Components of the message list

The message list consists of a header line, the messages and an operation dialog.

The header line contains the number of messages in the message list and matches the
information in the message line. Displays of the various priority levels are used to signal that
messages at these priority levels are to be found in the section of the message list which is not
visible.
Two possible formats can be selected for the individual messages.
The operation dialog is used to acknowledge and filter the messages and to select the display
format. The display selection dialog can be used to call up displays which are allocated to the
message producing tags.

vd0100us.bmp
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B 1.3 Components of the hint list

The components of the hint list are identical to those of the message list. The messages
displayed are hints and/or hint messages only.

The operation dialog also corresponds to that of the message list. The only differences relate to
the filtering of messages.

vd0410us.bmp
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B 2 Types of Messages

In the Freelance 2000 system, messages are divided into the following message types ac-
cording to their importance to the process:

System messages System messages have the highest priority level and are subdivided into
3 message groups S1 to S3. Messages of this priority level cannot be
configured or changed by the user. They are used to signal fault states of
the system. For a list of the system messages see Operators Manual,
Operator Station, System messages.

Fault messages Fault messages have priority levels 1 to 3. Messages of this type are
used to indicate e.g. alarm limit settings being violated.

Switch messages Switch messages have priority level 4. Messages of this type are used
to indicate switch events, e.g. valve open/closed.

Hint The option exists of configuring a hint for each fault message and switch
message. The configuration of such hints should give the operator the
cause of the message, options for eliminating the process anomaly and if
necessary further hints for operation. Hints appear only in the hint list.

Hint messages Hint messages have priority level 5. They are contained only in the hint
list and are solely for the operator’s information.
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B 2.1 Priority levels

Messages which arrive from the process stations can be of varying importance for the problem-
free running of the process. The Freelance 2000 system offers six different priority levels for
messages. Four display colors are allocated to these.

Priority level Type of message Display color
S1 - S3 System message blue

1 Fault message red
2 Fault message orange
3 Fault message yellow
4 Switch message yellow
5 Hint message -

The same color is used in the message line, message list and faceplates to indicate the
priority level of a message.

The colors indicated here are default settings of the Freelance 2000 system. The display
colors of the various message priorities can be changed to take account of particular
country- or company-specific requirements. Since a modification of this kind affects the
overall appearance of DigiVis and has safety-relevant aspects, this change should only
be made in collaboration with the responsible commissioning engineer or service engi-
neer. The Freelance 2000 documentation always refers to the standard color setting.
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B 2.2 Acknowledgment of messages

B 2.2.1 Types of acknowledgment

Two types of message acknowledgment are possible, visual acknowledgment and normal
acknowledgment.

Visual acknowledg-
ment This is available in the message line and the hint list. When used in the

message line, an entry is deleted without this having any effect on the
current status of the message in the process station or message list.
An indication is given in the hint list that the hint has been acknowledged
or it is deleted.

Acknowledgment This is available in the message list and, if configured appropriately, in the
message line also. The message is acknowledged in the process station
and also the message list. This changes the status of the message.

Visual acknowledgment does not replace normal acknowledgment; it is an additional
function.

B 2.2.2 Message acknowledgment strategy

The acknowledgment strategy comprises three different acknowledgment levels (levels 1-3).
Acknowledgment level 1 is the highest acknowledgment level. Messages which are configured
with this acknowledgment level must be acknowledged when incoming and outgoing.
Messages on acknowledgment level 2 must only be acknowledged when incoming.
Messages on acknowledgment level 3 do not have to be acknowledged.

A message is designated incoming when the situation giving rise to it has just occurred. It is thus
entered for the first time in the message line and message list.

Example: A message generated when a process value exceeds its limit will be con-
sidered as incoming until the value returns to the "normal zone."

A message is designated outgoing when the situation that caused it is no longer active. In
some cases, acknowledgment must be used to remove these messages from the message line
and the message list.

Example: A message generated when a process value exceeds its limit will be con-
sidered as outgoing when the associated value is again in the "normal
zone".
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B 2.2.3 Acknowledgment in the message line and message list

Depending on configuration, acknowledgment in the message line is by means of visual
acknowledgment or normal acknowledgment. The type of acknowledgment which is active is
indicated by the button: VA for visual acknowledgment, A for normal acknowledgment.

Only normal acknowledgment is available in the message list. The operating dialog provides
buttons for this.
Acknowledgment influences the message status and the following combinations can be
configured:

Acknowledgment
level

Message
Coming

not A

Message
Coming

A once

Message
Going

not A

Message
Going

A once

Message
Going

A twice

1 FS + FL FS + ST ES + FL ES + ST nv.

2 FS + FL FS + ST ES + FL nv. nv.

3 FS + ST nv. nv. nv. nv.

Message Coming The message at the process station is active.

Message Going The message at the process station is inactive.

FS The priority and the state of the message are displayed as a full symbol
to the left in the message list. The color of the symbol depends on the pri-
ority.

ES The priority and the state of the message are displayed as an empty
symbol to the left in the message list. The color of the number and the
sign depends on the priority.

FL The display flashes.

ST The display is static.

nv. The message is not visible.

A The message was acknowledged.
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B 2.2.4 Acknowledging in the hint list

Only visual acknowledgment is possible in the hint list. Visual acknowledgment has no
influence on the display of messages and their acknowledgment level in the message list. The
display of hints depends on visual acknowledgment and the state of the appropriate message.

Message
Coming

+
not A

Message
Coming

+
A

Message
Going

+
not A

Message
Going

+
A

BY WB BW nv.

BY Black text on a yellow background.

WB White text on a black background.

BW Black text on a white background.

nv. The message is not visible.

B 2.3 Filtering messages

The operation dialogs of the message and hint lists offer options for filtering messages. These
are filters for plant areas, priority levels and system message groups.

The filter settings assumed on selection of the relevant list can be configured. This filter setting
can only be made more restrictive if modified in operation.
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B 3 Acoustic Messages, Field Horn and Control Room Horn

For local alarming field horns can be connected to a binary output of the process stations. For
central alarming in the control room one control room horn can be connected to each operator
station.

The horns can be activated by:
• pre-processed field signals
• messages from the function blocks.
• system messages

Horn function blocks must also be configured in the process stations.

B 3.1 Activating horns by field signals

After preprocessing the field signals, a resulting binary signal must be connected to the input of
the horn function block.
To activate the control room horn, an event message is generated by the horn function block.
DigiVis activates the control room horn after evaluating this message.
To address the field horn, the output of the horn function block is connected to the field horn via
a binary output.

An event message is an internal message of the Freelance 2000 system. It is not visible
to the operator. Event messages are used at points where a Freelance 2000 process
station is able to control a function in the operator station directly. Examples of this are
the horn function and logs.

di0380uk.bmp

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section B Messages and Hints

B-15

B 3.2 Activating horns by messages

DigiVis evaluates the incoming messages from the process stations. If an incoming message
passes the set horn filter, the control room horn is activated by DigiVis directly.

If an incoming message passes the set horn filter and a field horn must be activated, DigiVis
writes a logic-1 signal to an internal input of the respective horn function block. The field horn is
switched on. As feedback, an event message is generated and sent to DigiVis.

di0381uk.bmp
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B 3.3 Acknowledgment in the field

After pressing the field acknowledge button, which must be connected to the input LR of the
horn function block, an active field horn is switched off directly.

An activated control room horn can also be acknowledged from the field. In this case the horn
function block generates an event message. After receiving this message DigiVis switches the
control room horn off.

di0382uk.bmp
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B 3.4 Acknowledgment in the control room

On selection of the HORN OFF button, DigiVis switches off an active control room horn. In the
case of an active field horn, a logic-0 signal is written to the internal input of the respective horn
function block by DigiVis. The field horn is switched off. As feedback, the horn function block
sends an event message back to DigiVis.

di0383uk.bmp
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B 4 Global Message Processing

The global settings apply to the whole Freelance 2000 system. This concerns the message and
acknowledgment behavior of messages on priority levels 1 to 4.

in the project tree → System → Global message processing

The global settings cannot be changed by the operators at the operator stations.

The acknowledgment strategies used can be set for fault messages (priority levels 1 to 3) and for
switch messages (priority level 4). It is possible to choose from three possible acknowledgment
strategies for each priority.

System messages and hint messages cannot be configured with a type of acknowledg-
ment but have a fixed setting. System messages have acknowledgment levels 2 and 3,
hint messages always have acknowledgment level 3.

di1304uk.bmp
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B 5 Local Message Processing

The local settings apply to individual operator stations. These include the settings for the
message line, message list, message list, hint list and horn activation.

Select in the project tree → System → Local message processing

double-click on operator station in the project tree

General data
Name Name of operator station

Message buffer
length This number defines the number of possible entries in the message list at

the operator station. A minimum of 10 entries must be configured and a
maximum of 2000 can be configured.

ts0500us.bmp
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Level of the message
buffer for reacquisition
after overflow This number defines the nominal level of the message list after an over-

flow. After an overflow has occurred, entries in the message list are de-
leted in accordance with a positive-displacement algorithm. This is re-
peated until the level within the message list corresponds to the value
stated here.

The positive-displacement algorithm is composed of the following steps:

1) Deletion of hint messages.

2) Deletion of active, acknowledged messages. First the oldest message
is deleted and then more recent messages are deleted consecutively.
Deletion begins with priority level 4 and continues consecutively to
priority level 0.

3) Deletion of the oldest inactive, unacknowledged message. Otherwise
the same as 2).

4) Deletion of the oldest active, unacknowledged message. Otherwise
the same as 2).

B 5.1 Tab Display

Message list
Display of Selecting Value or Long text specifies the output format of a message in

the message list at the control station.

Formats A choice of two display formats is available for fault and switch messages:

Value Sound Priority Time Plant

area

Tag

name

S-Text ST-Text M-value,

Dim.

Type Date

Long Sound Priority Time Plant

area

Tag

name

S-Text L-Text ST-Text Date

System messages have a fixed display format

System
message

Sound Group Time Plant

area

Tag

name

Fault text

Abbreviations:
Sound Label identifying messages connected with a configured sound file. For

system messages this field is empty.

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section B Messages and Hints

B-21

Priority Priority of the message with indication of whether incoming or outgoing.

Group System message group; specified by system.

Time Time of occurrence of the message. The resolution is 1/1000s.

Plant area Plant area to which the tag name is allocated.

Tag name Name of the tag which generated the message.

S text Short text for the tag.
L-text Long text for the tag.
St-text Status text of the message.

Measured value Measured value registered when the message was generated, e.g. limit
value.

Dim Dimension of the measured value.

Type Every message has a message type. For limit values, the message type
is the limit value type (e.g. HH for the second high limit value).

Date Only shown with the first message and after a date change. A date
change is indicated by a horizontal red line.

Fault text Explains the fault which has occurred in the case of a system message.

Message order Fixes the position of the current message in the message list. Thus the
current message appears at the top or bottom of the message list.

Message line
Message order Determines the position of the oldest message in the message line. Thus

with the current message right, the message line will be filled with new
messages from left to right.

Acknowledge
type With Acknowledge it is possible to choose between visual acknowledg-

ment and acknowledgment.

With visual acknowledge the VA button appears in the message line.
Messages in the message line are only visually acknowledged and must
be acknowledged in the message list.
With acknowledge the A button appears in the message line. Messages
in the message line are acknowledged normally.
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B 5.2 Tab Filter

The filters set here determine the way in which the message line, message list and hint list are
displayed.

The message filter settings are default settings which are taken over
loading the control station. They can be modified by the user for message
and hint list but only to make them more restrictive. This means that fur-
ther filter settings can be added but ones which have already been con-
figured cannot be turned off.

Station filter Only messages from the selected process stations will be displayed.

All All configured resources will be shown in the adjacent list.

Connected Only those resources to which a connection has been configured will be
displayed in the adjacent list.

Message filter Determines which messages appear in the message list. Settings can be
configured for the system message groups, priority levels and plant areas.

Area filter Determines from which areas messages will be displayed.

ts0501us.bmp
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B 5.3 Tab Hint List

The hint list shows a section of the hint list containing hints and hint messages. Hints are
configured for messages of priority levels 1 to 4 or as autonomous hint messages (priority
level 5).

Show the
current hints Fixes the position of the current hint in the hint list.

Hint filter This determines whether only the hints for priority levels 1 to 4 are to be
shown in the hint list, or whether the (priority 5) hint messages are also to
be included.

ts0502us.bmp
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B 5.4 Tab Field horn

Binary signals control the field horn. Therefore a function block HORN must be configured. See
Engineering Reference Manual, Functions and Function Blocks, Monitoring Function
Blocks.

Tag name The function block name indicates the tag name of the associated func-
tion block HORN at the process station.

Messages For system message groups S1 to S3 and priority levels 1 to 4 it is possi-
ble to indicate whether the field horn is to sound when messages are
Coming or Going or for both.

Area filter Determines, from which areas messages should control the field horn.

Ackn. field horn with
control room horn If the field horn is acknowledged together with the control room horn (the

control box is activated), the field horn is reset as soon as the control
room horn at the operator station has been acknowledged. If this field is
not activated, it cannot be reset by the operator station!

Stop sound with
field horn The local sound system on the DigiVis PC is deactivated by acknowl-

edging the field horn. Which of the operator stations has acknowl-
edged the field horn is of no significance in this case.

ts0503us.bmp
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B 5.5 Tab Control room horn

The notification that an event has occurred can also, in addition to the field horn, be made by a
sound board or relay board (control room horn).

Messages For system message groups S1 to S3 and priority levels 1 to 4 it is possi-
ble to indicate whether the control room horn is to sound when messages
are Coming or Going or for both.

Tone type For each priority, several sound files (WAV files) may be entered with or
without extensions. These files will be played back in succession and with
no interval.
The system loads the files from the standard DigiVis folder
\Freelance\wave\… It is also possible to specify the full path and filename,
e.g. c:\winnt\media\… The length of this input must not exceed 100 char-
acters. In accordance with the Play sound files in setting, the DigiVis
sound system will play the selected files for coming and going messages.

Rel.-T. If the notification takes place by means of signals, which are produced by
devices connected to the relay card, the relay terminal (1 to 8 possible)
for each priority level must be indicated.

ts0504us.bmp
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Play sound files in In addition to the sound files configured here for the various priorities,
sound files can also be configured for individual process messages. The
following three alternatives can be used to control their processing under
DigiVis:
• Priority order, oldest message,
• Priority order, newest message,
• Time order
• Priority-controlled: the sound file for the most important message
is repeated until such time as the message is acknowledged or super-
ceded by a more important message.

Time-controlled: The sound files of all coming messages are played
back once each in the order in which the messages arise.

See also Operators Manual, Operator Station, Messages and Hints,
Messages with sound files.

Pause between
two messages The minimal interval interposed between sound files for different mes-

sages or between repetitions of the same sound file for a particular mes-
sage.

Area filter Determines, from which areas messages control the control room horn.

Sound board The sound system of the DigiVis PC is active.
The sound system of the DigiVis PC is inactive. Configured sound files
will not be played.

Relay board The relay board of the DigiVis PC is active.
The relay board of the DigiVis PC is inactive. Configured relay termi-
nals will not stetted.

The relay card itself must be installed in Windows on the DigiVis PC. The program
DigiVis Configure offers the option of installing driver software for the relay card. For
further information see also also Operators Manual, Operator Station, DigiVis Instal-
lation, Modifying Installation.
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C 1 Display Access

C 1.1 General description - display access

The display access is a convenient means of quickly calling up the displays assigned to the
selected tag during process operation, thus obtaining selective information on the plant status.

Having selected a tag in DigiVis, the display selection dialog keys assigned to the tag are also
highlighted via the display selection dialog, apart from the selection fields for general displays
such as overview display, message list and system display. These display selection keys enable
one to call a faceplate (Tag), group display (Group), graphic display (Graphic), trend display
(Trend), time scheduler operator display (TS), sequential function chart display (SFC), signal
sequence log (SSL), disturbance course log (DCL) and operation log (OPL).

The Display access supplies data to the DigiVis display selection dialog, see Operators Manual,
Operator Station, Operating Philosophy.

C 1.2 Automatic display allocation

To a certain extent, display allocations can be specified automatically by the system. This
serves to reduce the effort for configuration.
When display allocation is called up, and when a plausibility check is carried out on an operator
station, the tags, displays and logs contained in the configuration database are checked. For
each tag, usage is established in the instances of all display types and log types.
When usage of a tag is discovered, the display or log is indicated as an entry for the display
allocation. If no usage and no cross reference is found, this is indicated by the entry "<unde-
fined>".

C 1.3 Call up the display access

After selecting a D-OS resource (station or pool) in the project tree, the displays / logs stored
there can be assigned to a tag.

If the general display pool is selected, the chosen display access applies for all operator
stations of the project. However, if the display access is chosen at a later date for an op-
erator station resource, the settings previously defined in the pool are overwritten for this
resource.

tt0001us.bmp
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→  System → Display access

C 1.4 Structure of the parameter mask - display access

tt0129us.bmp
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C 1.4.1 Display access editor

The tag, to which the displays are assigned, is selected via the windows Tag type and Tag name.
First, the type is selected in the window Tag type. After that, a list of all tags of this type that are
present in the system appears in the window Tag name. Having selected one of the tag names
from the window Tag name, the required display name/log can be entered into the displays/logs
provided.

Select tag
Tag type List of all tag types

Tag name List of all tags of one type with their names

Displays One display or log of each type can be assigned to each tag.

<empty> No display allocation of this display or log type for the selected tag.

<undefined> The system was unable to detect a display allocation for this display or log
type.
This entry may only be selected by the user in the event that the system did
not detect automatic allocation. An allocation detected by the system can only
be overwritten by selecting a different allocation or by entering <empty>.

CROSS REFERENCE The list of cross references is displayed for the selected tag.

Reset The automatic display allocation (cross references checked by the sys-
tem) is implemented again for the selected tag.

C 1.4.2 Default display

→ Click mouse on display type or
→ Select Define default display from the shortcut menu for the display name
→ display type designated with (D)

If several display types have been entered for one tag name, it is possible to designate a certain
display type. This will then be preselected under DigiVis in the display selector dialog.
In all cases, only one of the entered displays can be designated as a default display. To change
the default designation, simply click another display type.
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C 2 Overview Display

C 2.1 General description - overview display

During a Freelance 2000 project, one overview display can be configured for every operation
station. The configuration mask comprises 4 pages; each page comprises 4 lines and each line
comprises 6 segments, i.e. the overview display can feature up to 96 entries.

The overview display is configurable. Existing displays and logs can be listed in a plant-specific
manner, using a selector list. A freely assignable plant text and the line headers are used to
enhance clarity.

tt0210us.bmp
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C 2.2 Create a new overview display

An overview display is created and edited in the project tree beneath a resource operator sta-
tion or in the general display pool; for detailed information see Engineering Manual, System
Configuration, Project Tree.

Project tree menu → Edit → Insert below/above → Overview display

If an overview display is configured in the general display pool, this overview display will
be available in all operator stations.

C 2.3 Overview display configuration

→ DOUBLE CLICK the name of the overview display in the project tree

Displays and logs, which had been entered into the overview display but were later de-
leted, are displayed in red in the configuration mask and are reported as non-existent in
the error list during a plausibility check.

Caption text Max. 48 characters

Tabs Page 1 to 4 The overview display is configured on 4 pages, each with 4 lines.

Line Header Max. 77 characters per line

Segment Name of the display or log entered (6 per line)

tt0005us.bmp
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C 2.3.1 Enter display names

→ Select overview display segment → right mouse button → Select
→ Select display type and display name from the selector list
→ OK

The display selection list is opened via the menu item Select in the shortcut menu or
on pressing the function key F2. All displays and logs configured so far are listed ac-
cording to display types in the window which now appears.

Select an overview display segment from the configuration mask. The display name (if known)
can be entered directly or can be selected from the display selector list.

Abbreviations in the display selector list
DCL_D-OS Disturbance course log
FGR Free graphic display
GRP Group display
OPL Operator plant log
SFCP Sequential function chart display
SSL1 Signal sequence log, directly on printer
SSLN Signal sequence log, manually
TR_D-OS Trend display
TS_D-OS Time scheduler display

C 2.3.2 Plausibility check

The overview display is checked for syntactical and contextual errors. If errors are found, they
are displayed in a list. Implausible display and log names are shown in red in the configuration
mask, the plausible ones are shown in black.
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C 3 Group Display

C 3.1 General description - group display

A group display mask comprises 6 x 4 segments, i.e. the group display can feature up to 24
standardized depictions of tags.

The group display is configurable. A short text and a long text can be assigned to each group
display, by that e.g. a assignment to a process segment can be made. Existing tags can be
entered using the selector list. Accordingly, the standardized depictions of tags (faceplates) be-
come an integral part of the group display. The size of a faceplate is a function of the type. One
analog DEPICTION claims one of the 6 columns (4 segments), while one binary faceplate claims
only one segment. For user defined faceplates each rectangular size within the 6 x 4 raster is
possible.

tt0310us.bmp
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C 3.2 Create a new group display

A group display is created and processed in the project tree beneath a resource operator sta-
tion or in the general pool. For a detailed description see Engineering Manual, System Con-
figuration, Project Tree.

Project tree menu → Edit → Insert below/above → Group display

If a group display is configured in the general display pool, this overview display will be
available in all operator stations.

C 3.3 Group display configuration

→ DOUBLE CLICK the name of the group display in the project tree

Tags that had been entered but were later deleted, are displayed in red in the configura-
tion mask and are reported as non-existent in the error list during a plausibility check.

Short text A maximum of 12 characters are assigned to group display
Long text A maximum of 30 characters are assigned to a group display

tt0007us.bmp
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C 3.3.1 Enter a tag

→ Select group display segment → Call shortcut menu using right mouse button →
Select
→ Select function type and name from the selection list → OK

The tag selection list opens via the menu item Select in the shortcut menu or on
pressing the function key F2. All tags configured so far are listed acc. to function types in
the window which now appears. For abbreviations in the tag selection list see Engi-
neering Reference Manual, Functions and Function Blocks.

Select a group display segment from the configuration mask. The tag name (if known) can be
entered directly or can be selected from the selector list.

C 3.3.2 Plausibility check

The group display is checked for syntactical and contextual errors. If errors are found, they are
displayed in a list. Implausible tags are displayed in red in the configuration mask, the plausible
ones are displayed in black.
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C 4 Trend Display

C 4.1 General description - trend display

The development of process variables for a period of time can be graphically displayed with the
Trend Display. Up to six process variables can be depicted in each trend display. The number of
trend displays per operator station is unlimited.

A trend display can be used to show either the data captured by a trend data acquisition block
or any process variables.
If a trend data acquisition block is used, up to six values are logged with their respective time
stamps and placed in a buffer memory with 200 values per signal and, if required, transferred to
the operator station for Long Term Archival (see Engineering Reference Manual, Functions
and Function Blocks, Acquisition blocks).

Any six variables from the Freelance system may be specified for configuring a free trend dis-
play. An additional variable with the data type DATE&TIME can also be configured for each pro-
cess variable. The value of this variable is used as a time stamp for the process value.
If no separate time-stamp variable is specified, then for variables from a Freelance process
station the associated system variable <resource_name>Date.Time is used; in the case of
variables read from an OPC server into the Freelance system, on the other hand, the OPC-
server time stamp that was supplied with them is used.

In order to use a free trend display a gateway station of type 'TRN gateway' must be configured
in the project tree. (see Engineering Manual, System Configuration, Project Tree).
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C 4.2 Create a new trend display

A trend display is called and edited in the project tree beneath a resource operator station; for a
detailed description see Engineering Manual, System Configuration, Project Tree.

Project tree menu → Edit → Insert below / above → Trend display

C 4.3 Trend display configuration

In the project tree → Select trend display → Double click left mouse button

The trend display configuration comprises one parameter dialog with five tabs.

tt0410us.bmp
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C 4.3.1 Acquisition tab

General data
Name Name of the trend display, can be changed in the project tree.

Short text A short text can be assigned to the trend display. A maximum of 12 char-
acters may be entered.

Long text A long text can be assigned to the trend display. A maximum of 30 char-
acters may be entered.

The short and long texts are also printed along with the project
documentation.

Trend data acquisition block or
Acquisition of variables

Parameter specifying whether the trend display is based on data from a
trend data acquisition block or on independent process variables.

Name Name of the trend data acquisition block in the process station.
The function key F2 is used to select a trend data acquisition block.

Cycle time In the time interval configured the process variables are read and stored
as trend data.

tt0430us.bmp
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Variable
Value Name of free trend variable. The function key F2 is used to overlay the list

of known variables in the system.
Time stamp Name of the process variable whose value is used as the time stamp for

the variables entered under value. The function key F2 is used to overlay
the list of known variables of data type DT in the system.
If no separate time-stamp variable is specified, then for variables from a
Freelance process station the associated system variable <re-
source_name>Date.Time is used; in the case of variables read from an
OPC server into the Freelance system, on the other hand, the OPC-
server time stamp that was supplied with them is used.

C 4.3.2 Display tab

Display
Colors Selection of colors for foreground, background and window of the trend

display (3 colors).

Value windows Determine if a max. of 3 or all trends within the trend display range should
be displayed.

tt0431us.bmp
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Variable
description For the trend specifications, the name, short text, dimension and tag

are assigned to the individual trends. The number of trends is equal to the
number of connected inputs on the trend acquisition module.

Name The Name assigned to the trend.

Short text The Short text assigned to the trend.

Dimension One Dimension can be assigned to the trend. The Dimension can be en-
tered directly or can be selected from an existing list, using the arrow keys
or mouse.

Allocated tag Tag name for faceplate to be called up in DigiVis by double click.

Color Color selection for each trend curve. All colors available for graphic dis-
plays are available.

Default settings for color:

Trend 1 signal red
Trend 2 signal yellow
Trend 3 signal blue
Trend 4 signal green
Trend 5 signal cyanide
Trend 6 medium magenta

The text entries or text selection for Name, Short text and Dimension are depicted in
DigiVis with the trend. These entries are not mandatory.
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C 4.3.3 Area options tab

Trend area options The parameter definition of position comprises the time range for depiction
on the X-axis, the definition of scaling on the Y-axis and band start / band
end for up to six trends.

Time gaps Maximum time interval between two successive time stamps of a value.
The values in this internal are interpolated (see Operators Manual, Ope-
rator Station, Trend display, Interpolation). Entry is made acc. to IEC
1131-3 time format.

Time axis The input field must be filled in.
The time range specifies the yardstick on the X-axis for the trend depic-
tion in DigiVis. Entry is made acc. to IEC1131-3 time format. The highest
value amounts to about T#24d20h31m23s.

Example:
T#2147s or T#24d20h31m23s

Band start The Band start specifies the value for scale start of the Y-axis for depict-
ing an individual trend. See figure below.

Values entered as real numbers.
The value range is 0.0 and ±9999999999.9. The value for the band start
must be less than the value for the band end.

% The percentage value specifies the position of the scale start for Band
start % on the Y-axis. See figure below.
The percentage values must be entered as integers. The value range is
0 - ±5000%.
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Band end The Band end specifies the value for the scale end of the Y-axis for de-
picting and for the individual trend. See figure below.

Values entered as real numbers. The value range is
0.0 - ±9999999999.9. The value for the band end must be greater than
the value for the band start.

% The percentage value specifies the position of the scale end for Band end
% on the Y-axis. See figure below.
The percentage values must be entered as integers. The value range is
0 - ±5000%.

Example of a trend display:

The following settings have been chosen for the parameter definition of the position:

Band end: -10.0 Band end: 110.0
Band start %: 20 Band end %: 80

di1311.bmp
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C 4.3.4 Archive tab

Archive A decision is made whether the trend data Archiving is to be effected on
the operator station. If Archiving is activated, specify the following: Ar-
chive duration, Start up mode and if the old archive data should be de-
leted. On the operator station only one trend display with a fixed size con-
figured for an archive file (as ring memory).

Enable Archiving The trend data are archived as a function of the Start up mode.

Delete old archive The old archive will be deleted on restarting the operator station (new
start of DigiVis).
Archiving is resumed with a chronological gap after a restart.

If archives do not match after a restart, e.g. the number of trends
have changed in the meantime, the old archive is saved as a file.
The old archive files are assigned a serial extension from 001 to
999.

Archive duration The Archive duration is entered according to the IEC 1131-3 time format.
The entry can be made in days, hours, minutes and seconds. Inputs less
than 1 s lead to error.
Maximal 24855d = 68 years

Example:
T#24855d or T#24d20h31m23s
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Apart from the input field for the archive duration, the maximum hard disk
requirements for archiving on the operator station are given in kilobytes.

The size of the trend file is determined by the archive duration.
This size can never be exceeded by the Trend file since data are
stored in a ring memory. This means that on reaching the archive
duration, the oldest data are always overwritten again by the current
data.

Start up The Start up defines whether trend data recording and archiving should
start immediately after starting DigiVis.

Ready Acquisition and archiving are ready but not yet started after starting
the operator station. Start is triggered by changing a flank at one input
of the trend acquisition module. See Engineering Reference Manual,
Functions and Function Blocks, Acquisition blocks.

On Acquisition and archiving are switched on after starting the operator
station.

Archive name The file name for the trend archive file on the operator station hard disk
can be specified.
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C 4.3.5 File transfer tab

File transfer
Here is decided whether - and in what way - a copy of the trend file should be transferred from
the DigiVis-PC to another PC in the Freelance 2000 net. The PC that is to receive the archive
must be a communications subscriber in the net (network card and installed FTP server, see
Engineering Manual, System Configuration, Installation: DigiTool). It is also possible to
export the Archive file to a Windows drive of the DigiVis-PC.

To visualize the trend archive data and to convert them into the CSV format, the Freelance
2000 supplementary program DigiBrowse can be used for this PC.

File transfer (FT)
Start export at Cyclical transfer enabled as soon as the configured time is reached.

No cyclical data transfer.
Start time for the cyclical data transfer. Make entry in the DT format.

Reexport every Here it is determined at which time periods data transfer is effected. Make
entry in the TIME format.

incremental
Only the data acquisitioned since the last data transfer are transmitted.

complete
All archived data are transmitted.
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Export on event Data transfer takes place as a function of the state of the entered
event module. It is compulsory to input an event module.

With function key F2 a selection list appears.

No event-controlled data transfer.

Reexport on every event
Data transfer will occur only in case an event flank increases.

cyclic every
Data transfer will occur only when an event flank increases. From this
period on, the data transfer will be effected cyclically as long as the
event is current.
Which time periods the data transfer should follow are determined
here. Make entry in the TIME format.

incremental
Only the data acquisitioned since the last data transfer are transmit-
ted.

complete
All archived data are transmitted.

Access manually
export The operator at the operator station can enable file transfer.

File transfer cannot be enabled manually.

Target Here the target of the file transfer must be defined. As target a PC in
the Freelance 2000 net can be used; it must feature a network card and
an installed TCP/IP license. Ideally, the supplementary package Digi-
Browse should be installed on this PC to permit visualization of archive
files of the trend and of logs.

Station Specification of the IP Address of the target computer.
If you are operating your Freelance 2000 system in a network, you
should obtain the IP addresses from your network manager, because this
address must be selected unambiguously worldwide. If you want to
use the DigiVis PC as file transfer target, its IP address must be
given here.
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Path If the archive files are to be copied into a specified directory, the complete
directory name must be given here. It is important to enter a backslash \
as last character for a DOS computer. If e.g. only C:\temp is given as di-
rectory, the file c:\tempXXXX.001 is generated on the target computer,
with the Xs denoting the first four characters of the configured archive
name.

It must be noted that the target station is responsible for further
processing of the files during export. The copied file is only tem-
porary and is overwritten again with the next export of the corre-
sponding archive.

File The Export files are saved in the file name given under target path.

Directory (8.3) The export files are saved in the directory given under the target path
with names generated by the system using the current date and time.
The file name has a length of 8 chars with a 3 characters extension.

Directory The export files are saved in the directory given under the target path
with a name generated by the system using the given name and the
current date and time.

Suffix for incremental/
complete In order to distinguish between files containing complete or incre-

mental data sets, either '_INC' or '_FULL' is appended to the basic file
name. This suffix prevents a situation from occurring where complete
and incremental files are allowed to overwrite one another.

FTP timeout FTP services are synchronous services. To prevent blocking the sys-
tem, a maximum time, in which an FTP service must have been exe-
cuted, must be specified.

User name This user name must be entered. If necessary, this name is checked by
the FTP server.

Password This password can be defined when setting up the receiving PC. This en-
sures that only the subscriber who knows this password can store files in
the PC. In this manner abuse or manipulation by non-authorized sub-
scribers can be prevented in open nets.

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section C Standard Displays

C-26

C 5 Sequential Function Chart Display

C 5.1 General description - SFC display

The Sequential Function Chart (SFC) is a user-defined net of steps and transitions.
The action block is defined as a step and the step-enabling condition as a transition. Steps and
transitions are represented by graphic symbols. The representation, symbol type and color of the
symbols depend on the status of the steps and transitions.

Each SFC program begins with an Initial Step and ends with an End Transition. All steps are
inactive during initialization of the SFC program.
The initial step is activated at the start of the SFC program, all other steps are inactive. The start
of the SFC program begins with its Enable, i.e. New Start or Repeat Time have been reached or
have expired.
The end transition terminates one sequence function chart run, after which all steps are once
again in the inactive state.
For configuration of the sequence function chart (SFC) and definitions see Engineering
Manual, IEC 61131-3 Programming, Sequence Function Chart (SFC).
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C 5.2 Create a new SFC display

A sequence function chart display is created and edited in the project tree beneath a resource
operator station or in the operator station pool, for detailed description see Engineering
Manual, System Configuration, Project Tree.

Project tree menu → Edit → Insert above/below → SFC display

If a sequence function chart is configured in the general display pool, this sequence
function chart will be available in all operator stations.

C 5.3 SFC Display configuration

→DOUBLE CLICK the name of the SFC display in project tree

General data
Name The name of SFC display, changeable in project tree

Short text Short text assigned to the SFC. It can be up to 12 characters in length. All
characters are permitted.

Long text Text in the header of the SFC. It can be up to 30 characters in length. All
characters are permitted.

Allocated SFC program
SFC program name This input field must be filled out.

Here, enter the name of the sequential function chart program of the pro-
cess station to be operated with the SFC display.
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C 6 Time Scheduler Display

C 6.1 General description - time scheduler display

With a time scheduler, time-dependent analog values are output and can be sent to other func-
tions, e.g. to a controller as a set point input. In addition to the Time Scheduler Faceplate,
there is an entire-page time scheduler display.

This offers a comfortable means of displaying the set-point trend or the actual trend and of op-
erating the time scheduler. If desired, the allocated faceplate (generally the faceplate of the
postconnected function block) can be included in the time scheduler display.
The time scheduler display has been standardized and parameters must only be defined for the
short and long text, the allocated time scheduler block name and the faceplate.
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C 6.2 Create new time scheduler display

Creating and editing a time scheduler display is carried out in the project tree below a resource
operator station. For a detailed description, see Engineering Manual, System Configuration,
Project Tree.

Project tree menu → Edit → Insert below → Time scheduler display
→The time scheduler display name is entered in the configuration window
→The time scheduler display is entered in the project tree

If a time scheduler display is configured in the general display pool, this time scheduler
display will be available in all operator stations.
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C 6.3 Time scheduler display configuration

→Double-click on the time scheduler display name in the project tree

General data
Name Time scheduler display name, defined in the project tree and included

here for information only.

Short text Short text allocated to the time scheduler display: max. 12 characters

Long text Long text allocated to the time scheduler display: max. 30 characters

Allocation
Tag name of TS Name of the allocated time scheduler. This input field must be filled.

Tag name for
display access Name of the module whose faceplate is displayed in the time scheduler

window. This entry is optional.

The F2 function key gives a list of tags, which can be entered here.
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D 1 General Description - Graphic Display

In addition to the standard displays, custom graphic displays for observation and operating the
process can be used on an operator station. These graphic displays can be created with the
DigiTool graphic editor. The state of a process can be depicted in numerous respects with such
graphic displays. The static and dynamic graphic objects available make possible a varied
graphic representation of the running process. Use of the various animation options makes it
possible for the plant operators to observe process events in context at all times.

Each graphic display consists of static and dynamic elements. The static elements are made
up of basic objects, such as lines, circles, texts and bitmaps. Available as dynamic elements
are special graphic objects (such as alphanumeric displays and bar graphs) with which current
process values can be displayed, either as numeric values or graphically. Operable elements
form another category; they can be used to trigger a display switch, call up a tag allocation
faceplate, acknowledge a message or write values to process variables. The states of the
dynamic display elements in DigiVis are determined by the values of the assigned variables
and messages in the Freelance 2000 common data base.

Graphic symbols can be created from several single graphic objects. These new objects can
then be processed further, just like any single graphic object. Graphic objects may also be
defined as macros and stored in macro libraries. These libraries can be used as often as
required, even in other projects.

The size of the draw area can be adjusted to suit the monitor settings (640x480, 1024x768 or
1600x1200 pixels).
The size ratio, as well as the current position of the cursor in the drawing area, are displayed in
a toolbox.

Further functions include the editing of two displays simultaneously. The first display is a
named program in the project tree. The second display, called the graphic pool, possesses
the same graphic characteristics as the other display and is always loaded simultaneously with
the project. In the graphic pool display, complete displays, partial displays or graphic symbols
can be temporarily saved for later use. The contents of the graphic pool are retained when
another display is selected.

A number of 3D-effect graphic objects have been pre-prepared to help create complex process
displays. These graphic objects can be found in the exported graphic displays
Aggregates.dmf, Alphanumeric.dmf, CompController.dmf as well as Objects1.dmf and
Objects2.dmf on the installation CD; a readme.txt file is also included.
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D 2 Graphic Editor Interface

The graphic area consists of the title line, the menu line, the draw area, the status line and the
toolbox.

Title line
Menu line

Draw area with grid
switched on, crosshairs
and toolbox.

Status line with
user name
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D 2.1 Additional features of the graphic editor

Graphic editor behavior is based on that of standard Windows programs. In addition, the
graphic editor offers a number of special functions to simplify the preparation of a graphic
display and its incorporation into the project database.

F2 key Call up a selection list.
If a selected configuration mask field is to be filled in with a reference to
some project element, the name of that element can, in general, either be
typed in directly or chosen from a list of all possible entries. This list can
be called up by pressing the F2 key.

Example 1: When during configuration, the name of a process variable is
expected, the list called up by pressing F2 contains all process variables
that have been configured in the current project.

Example 2: When configuring a dynamic graphic object, the name of an
associated static object is expected. Pressing F2 brings up a list of all
static graphic objects that are available in the graphic display.

Cursor keys The cursor arrow keys can be used for precise positioning of the cursor in
the draw area. With each keypress, the cursor will be moved in the
corresponding direction by exactly on screen pixel. If the grid is turned on,
the cursor will be moved by one grid unit. See page D-11, Snap / Grid.

F5 key Display cross references
If the F5 key is pressed in an edit field containing a variable name, the list
of cross references for that variable will be displayed. It is then possible to
branch directly to any of the programs shown in the list.

Tool tip If the cursor is moved over a graphic object which has had a name
assigned to it, the name and type of the object is displayed in the form of
a tool tip.

ESC key As long as an object has not yet been defined completely, the
configuration can be abandoned by means of the ESC key. The
unfinished object is deleted and the graphic editor is set in standard
mode.
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D 2.2 Menu overview

Display Saves the graphic display,
Performs plausibility check of the graphic display,
Exports and imports graphic displays,
Exits the graphic editor, returning to the project tree.

Draw Creates static graphic objects such as lines, rectangles, text etc.,
Inserts bitmaps.

Edit Undoes or repeats last action,
Groups graphic objects to form new objects, or ungroups them again,
Cuts, pastes, deletes, copies graphic elements,
Mirrors or rotates graphic objects,
Places graphic objects in the foreground or background,
Switches to the graphic pool display.

Change Changes attributes of lines, areas, texts and text contents,
Shifts or deletes points of polygons and polylines,
Assigns names to graphic objects,
Selects the background color for the display.

Macro Loads or saves macro library,
Creates, edits and inserts macros.

Animate Re-edits dynamic objects,
Creates dynamic objects such as bar graphs, fill areas, etc.

View Shows the complete display without editor help markings,
Redraws graphic,
Selects setting of zoom and visible region.

Options Hardcopy,
Adjusts display size,
Sets grid setting, threaded cursor,
and toolbox position.

Back Returns to calling point.

Help Calls up the on-line help system.
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D 2.3 Draw area

The draw area is the user’s actual working area for creating and editing displays. It is located
between the main menu line or toolbar and the status line and fills the entire screen widthwise.
With the toolbox switched on, the visible draw area may be restricted as a result of overlapping.
Using the zoom function it is possible to zoom in or out on a section of the display being edited.
The Overview function is used to display an area corresponding to 9x the draw size. The actual
draw area is shown in the center, marked with a border.

The coordinates on the draw area run from left to right and from top to bottom. The coordinate
origin is at the top left-hand corner. The coordinates of the moving graphics cursor are shown in
the toolbox. In addition, the coordinates are used to indicate the position of display objects in the
parameter dialogs and are shown there.

D 2.4 Toolbox

Information about the graphic display is shown in the toolbox. This window can be positioned with
the Options → Toolbox menu item. It can be placed at the right, left, top or bottom of the screen
and it can be hidden with the off setting. Wherever it is originally positioned, it can be moved
about freely on the screen.

A graphic name or the term ”Pool” (for graphics pool) shown in red indicates
that the corresponding display is the visible one. It is possible to toggle between
the two displays with the Page Up/Page Down keys or with the help of the
menu.

Selected resolution of the X- or Y- coordinates.

Display of selected Zoom setting.
x/y coordinates of the cursor position.

Change the global line attributes (line thickness, color and style). All
subsequent lines receive these attributes. When selecting or drawing a line, the
text Line disappears and a line with the pre-selected attributes is displayed on
this.

Change the global area attributes (foreground/background color, fill pattern).
All subsequent graphic items receive these attributes. When selecting or
drawing one of these items, the text Area disappears and a rectangle with the
selected color and fill is displayed on this button.

Change the global text attributes (e.g. foreground/background color, size). All
subsequent texts receive these attributes. When selecting or entering text, the
text type and color selected is displayed on this button.

Changes to individual graphic symbols are carried out under Change. The
selection windows are described in detail in the corresponding section of this
document.
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The second section of the toolbox contains one button for selecting and one button for each
type of graphic object. After an object type has been selected, any number of objects of the
same type can be drawn one after another. This drawing mode ends when a different object
type is selected or the selection button is clicked.

D 2.5 Status line

The status line forms the lower border of the draw area. In it, the editing processes or the
execution instructions of the actions selected are summarized. The name of the graphic display
and the USER name are shown at the rightmost end.
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D 3 Basic Settings for the Draw Area

The settings for the draw area are made via the Options menu.

D 3.1 Hardcopy

→Options → Hardcopy → Display only,
→Windows print options mask (install printer if necessary), → OK.

The draw area is output to the printer.

→Options → Hardcopy → Whole screen,

The whole screen is output to the printer.

D 3.2 Snap / Grid

→Options → Snap/Grid.

Grid size from 10 to 200.

Snap active, or grid visible, respectively.
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In order to achieve more uniform positioning, it is possible to display a Background Grid. There
is an option of 5 fixed grid sizes. The grid setting applies both to the graphic and to the graphic
pool displays. While a display is being constructed the grid can be altered and switched on and
off.
When Snap is activated, only the grid points are available for positioning, i.e. the user does not
have to click on the desired grid point exactly, but only sufficiently near it. The grid point nearest
to the cursor is then selected. The grid and snap settings are independent of each other, i.e. a
grid may be defined without snap being activated, or snap may be activated without a visible grid.

D 3.3 Toolbox

→Options → Toolbox → Off, Right, Left, Top or Bottom.

If Off is selected the toolbox is not visible. Right, Left, Top and Bottom cause the toolbox to be
positioned along the respective edge of the screen.

For a description of the toolbox, see page D-9.

D 3.4 Limiting the draw area

→ Option → Limitation → 640x480, 1024x768, 1600x1200 or Off

The area in DigiVis available for a graphic display varies, depending on the resolution setting of
the monitor. The standard size (10240 x 6184 virtual pixels) is optimized for a monitor
resolution of 1280 x 1024. For the monitor resolutions 640 x 480, 1024 x 768 and 1600 x 1200
pixels, a limitation line can be shown in the lower section of the graphic display. This enables
graphic objects to be positioned perfectly in the draw area available.
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D 3.5 Update display size

→ Option → Update display size

This menu choice is used for adapting graphic displays from earlier versions of the software to
the new standard display size. In earlier versions graphic displays were sized at 10240 x 5312
virtual pixels, while from version 6.1 on the standard size is 10240 x 6184 pixels.

The current display size is set to the new default values which apply from version 6.1.

D 3.6 Threaded cursor

→Option → Threaded cursor.

Crosshairs with their intersection point at the cursor arrow are switched on. They extend over the
entire draw area in the graphic display.

D 3.7 Background color

→Change → Background color.

Each graphic display and the graphic pool display may be assigned its own draw area
background color.
After selecting Background color, a window appears showing the available colors. To enable
these colors to be accessed more quickly they are subdivided into a number of color groups. For
background color, the following color groups are allowed Static colors, Media colors and Free
colors. See also page D-13, Color selection.

D 3.8 Color selection

During the process of creating a graphic display, colors are specified for the background, the
static graphic objects and the states of the dynamic graphic objects. All such color settings are
made in the same color selection dialog box. This window is called up from within the different
alteration masks.
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All the available colors are subdivided into various different color groups. The groups can be
shown and hidden separately, and a direct jump to a particular color is also possible.
Each group can be used in any application, except display background.

The special colors group is an exception. The invisible option can only be selected for line
attributes, as a text background and for animation; it has the effect that the lines or graphic
objects are displayed as invisible, i.e. transparent.

The Original colors setting can only be used in animation. Here, the original colors of the graphic
object remain intact and are not altered by any animation color settings.

Special colors
Invisible no color, but invisible, i.e. transparent.
Original colors the colors of the static graphic object are used.

Groups Selection of the various color groups displayed in the color selection
window.

Static colors general colors.
Message colors colors to display alarms.
Signal colors colors to display signals.
Media colors colors that are displayed flashing off and on.
Free colors colors for display of color graphs.

Go to: After entering the color groups ( ) the buttons STATIC, MESSAGE, SIGNAL,
MEDIA, FREE are activated and can be selected. Following selection, the
selection is positioned at the start of the selected color group in the color
selection dialog box.
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D 4 Drawing Static Graphic Objects

The following static graphic objects are available: line, rectangle, polyline, polygon, ellipse, arc,
circle segment, text, bitmap and message type symbol. All static graphic objects are under the
Draw menu.

Graphic objects are displayed with their various attributes such as color, width, style. Attributes
can be altered via the toolbox or the Change menu. After drawing one graphic object you must
select the next one from the Draw menu. The F8 key can be used to draw another object of the
type just completed.

The appearance of the objects is determined by their attributes.

The following attributes are available in the graphics editor:

Line color: 237 colors and invisible.
Line style: continuous, dashed, dotted, dash-dotted.
Line width: 6 widths.
Arrow: left / right / arrows on both sides.
Corner: the corners can be rounded off in four stages,
Foreground and
Background: 237 colors each,
Fill pattern: 15 patterns and invisible.

For text objects the following attributes are available:

Size: text size in pixels.
Alignment: horizontal or vertical.
Text style: Bold and/or italic and/or underlined.
Fix point: Start, middle, end, top, bottom.
Char. font: at present Arial, Courier New and MS Sans Serif
Foreground color 237 character colors.
Background color 237 colors and invisible.
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D 4.1 Line

→Draw → Line,
→Mark starting point with mouse click, a construction line appears, and its end point

follows the cursor arrow,
→Mark end point by clicking mouse.

A line here means the shortest connection between two points.

Lines are specified with the attributes line color, line style, line width and
arrow.

D 4.2 Rectangle

→Draw → Rectangle
→Mark starting corner point by clicking mouse, a frame appears, and its end corner

point follows the cursor arrow,
→Mark end point by clicking mouse.

A rectangle is a graphic item having four sides and four right angles. A square is a
particular form of rectangle.

Rectangles are specified with the attributes line color, line style, line width,
corner, foreground color and background color and fill pattern.
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D 4.3 Polyline

→Draw → Polyline
→Mark starting point by clicking mouse, a construction line appears, and its end point

follows the cursor arrow,
→Mark end point of the section by clicking mouse; this point now becomes the starting

point of the next section,
→Mark end point of the next section by clicking mouse,
→Mark end point of the polyline by double-clicking.

A polyline consists of any number of construction points. In each case the points
are connected by lines. By activating the right-hand mouse button, the last end
point is deleted and a new point can be defined.
It is possible to subsequently alter the construction points of existing polylines (see
Change → Points).

Polylines are specified with the attributes line color, line style, line width,
arrow and corner.

D 4.4 Polygon

→Draw → Polygon
→Mark start by clicking mouse, a construction line appears, and its end point follows the

cursor arrow,
→Mark end point of the section by clicking mouse; this point now becomes the starting

point of the next section,
→Mark end point of the next section by clicking mouse, an area is formed,
→Mark end point of the polygon by double-clicking.

A polygon is a closed frame which, like the polyline, can consist of any number of
construction points. The first and the last point of the polygon are always
connected.
By activating the right-hand mouse button, the last point can be deleted and a new
point can be defined.
It is possible to subsequently alter the construction points of existing polygons (see
Change → Points).

Polygons are specified with the attributes line color, line style, line width,
corner, foreground color and background color and fill pattern.
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D 4.5 Ellipse

→Draw → Ellipse
→Mark starting point by clicking mouse, a frame appears, and its end point follows the

cursor arrow,
→Mark end point by clicking mouse.

The starting point lies outside the ellipse and is the corner of an invisible rectangle which
bounds the ellipse. The size, position and form of the ellipse or circle is determined by
moving the cursor away from the starting point.

The ellipse is a closed graphic item. A special form of the ellipse is the circle.

Ellipses are specified with the attributes line color, line style, line width,
foreground color and background color and fill pattern.

D 4.6 Text

→Draw → Text
→ Mark starting point by clicking mouse, a text input window appears. The starting point

is one of the frame's corners or center points, depending upon the settings in the text
attributes dialog box.

Words, fixed numeric values or special characters can be displayed as single line.

Texts are specified with the attributes size, alignment, attributes, fix point,
character font, foreground and background color.

All text strings of a graphic display are connected within a list. Instead of input a
text directly into the edit field you can use the F2 key to display this list to select a
text entry.
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D 4.7 Arc

→Draw → Arc
→Mark starting point by clicking mouse, draw circle or ellipse
→Finish it by clicking mouse,
→Mark starting point of the arc by clicking mouse,

move the cursor clockwise: arc gets larger,
move the cursor anti-clockwise: arc gets smaller,

→Mark end point of the arc by clicking mouse,

Subsequent changing of the arc size is not possible.

The arc is part of the circumference of an ellipse or a circle. The start and end
points are connected by a curve.

Arcs are specified with the attributes line color, line style, line width and
arrow.

Construction of an arc:
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D 4.8 Circle segment

→Draw → Circle segment
→Mark starting point by clicking mouse, draw circle or ellipse,
→Finish it by clicking mouse,
→Mark starting point of the circle segment by clicking mouse,

Moving the cursor clockwise: Circle segment gets larger,
Moving the cursor anti-clockwise: Circle segment gets smaller,

→Mark end point of circle segment by clicking mouse.

Subsequent changing of the segment size is not possible.

The circle segment represents a certain part of a circle or ellipse diagram. It is a
closed graphic item.

Circle segments are specified with the attributes line color, line style, line
width, foreground color and background color and fill pattern.

Construction of a circle segment:
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D 4.9 Bitmap

→Draw → Bitmap
→Mark the upper left-hand corner of the insertion position with a mouse-click,

whereupon the bitmap dialog will appear.

Stretch X (%): Bitmap scaling on x-axis (%),

Stretch Y (%): Bitmap scaling on y-axis (%),
(with the standard stretch values of 100% on each axis, the bitmap is
imported with its original size, i.e. with no distortion),

Transparent: Throughout the whole bitmap, all instances of the upper-left-pixel color
are replaced with ‘invisible’; i.e. the bitmap is imported with a
transparent background color.

Preview: Displays the selected bitmap,

IMPORT: Opens the dialog for selecting a bitmap file,

EXPORT Opens the dialog for writing the selected bitmap to a file.

Bitmap files can be imported in BMP format. No other formats are supported at present. If the
DigiTool PC is being operated with the 256 colors setting and a bitmap is imported with more
color information, then the colors in the bitmap are mapped onto the static colors of the graphic
editor.

Imported bitmaps can be moved, scaled, mirrored and named. The contents of a bitmap cannot
be altered in the graphic editor.
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D 4.10 Message type symbol

→Draw → Message type symbol

Different static graphic objects can be displayed in DigiVis as a function of a message type.

This graphic object can only be used in conjunction with a graphic symbol that has been
animated on message points. See page D-54, Graphic symbol and page D-30, Bit allocation
tab.

Symbol name List of static graphic object names that have been assigned to a message
type.

Message type List of message types used in function blocks having a faceplate.
For list of message types and their meanings, see Engineering Manual,
Operator Station, Logs, Message types / Limit types.

<no message type> The graphic object assigned here will be displayed when the associated
message does not have a message type, or when the associated
conditions for displaying a message have an empty intersection.

Show all symbols Upon switching to the graphic display, all objects assigned to this
message symbol are displayed.

DISPLAY Switch to graphic display in order to assign a static graphic object to the
previously selected message type.
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→Select a line in the dialog → Button DISPLAY

→Switch to the graphic display
→Choose an existing static graphic object or create a new one
→Return to the Message type symbol dialog with → Edit → Return to object...
The name of the graphic object will be shown in the Symbol name column in front of the
previously selected message type.

→Select a line in the dialog window → F2 key
→Show a list of the static graphic objects in the graphic display,
→Select an object from the list
The name of the graphic object will be shown in the Symbol name column in front of the
selected message type.

A static graphic object can be used as many times as desired within a message type symbol. As
many message types as desired can be assigned graphic objects; the entire list need not be filled
out.

Example 1:
The newest (most recent) message from the plant area is always to be depicted in DigiVis.
1. Create a message type symbol (Draw / Message type symbol).
2. Draw and assign static graphic objects to the message types which are to be displayed in

DigiVis.
3. Create graphic symbols and assign all message points of the plant area.
4. With the help of the animation functions, configure the system to always display the newest

of the pending messages.
5. Assign this graphic symbol to the previously created message type symbol.

In DigiVis the message type of the most recent message will be determined from the set of all
assigned messages. The graphic object assigned to this message type will be displayed.

Example 2:
The message type configured to a particular message point is to be depicted in DigiVis.
1. Create a message type symbol (Draw / Message type symbol).
2. Draw and assign a static graphic object to the message types which can be configured for

the message point..
3. Create a graphic symbol and assign a message point (e.g. the 1st message point threshold

of a controller).
4. Assign the message type symbol just created to this graphic symbol

In DigiVis the message type of the message point will be read and the associated graphic object
will be displayed.
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D 5 Animate, Dynamic Graphic Objects

The class of dynamic objects includes objects used in DigiVis both for depicting/observing
process dynamics and for operating the plant, i.e. for operating on process variables. These
objects will be called observation objects and operation objects respectively. All these objects
are located under the Animate menu item. The variables used here for animation of the graphic
display can be newly generated from within the graphic editor or, if already configured, can be
selected from the variable list with the F2 key.

For depicting changing process states, the most commonly used dynamic graphic objects are
the following: bar graphs, fill areas, alphanumeric displays, graphic symbols, self-animated
objects and trend windows. The following techniques are available to animate observation
objects:

• Display the current value of a variable numerically in any format desired.
• Display the contents of a string variable as text.
• Display a configured message text.
• Display different static graphic objects as a function of configured message types.
• Depict analog values with bar graphs or arbitrarily shaped fill areas, representing, for

example, levels in containers.
• Have graphic objects move in the graphic display as a function of an analog value.
• Have the graphic attributes of an object (colors, line width) change as a function of binary

process values.
• Have the graphic attributes (colors, line width) of an object change as a function of

messages.
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The dynamic graphic objects most commonly used for plant operation actions in graphic
displays are the following: selection fields, buttons, button fields and radio button fields. These
operation objects can be configured to trigger the following actions in DigiVis:

• Call up a tag allocation faceplate,
• Switch to any other display,
• Write a pre-determined value to a variable,
• Write an operation value to a variable,
• Acknowledge a message.

These operation actions can also be initiated by a display object.

In DigiVis, when a graphic display is updated, all dynamic objects are placed in front (on top) of
any static display elements. This can be altered by making the static elements part of a
dynamic object and designating them as foreground or background components within that
object. Such grouping makes it possible, for example, to display scale markings on a bar graph.

D 5.1 Create a dynamic graphic object

→Animate → Select type of dynamic graphic object,
→For a new bar graph, alphanumeric display, selection field, button, button field, radio

button or trend window click mouse to indicate the desired object position.
→Parameter definition dialog is displayed

The editing functions under the Edit menu are only partly usable on dynamic graphic
objects.

The system automatically assigns a name for each new dynamic object, and the name is
shown in the general section of the parameter dialog. It can be changed by the user at any
time. Object names must be unique within a graphic display.

D 5.2 Delete dynamic object

→Select dynamic graphic object → Edit → Delete.

→Select dynamic graphic object → DELETE.
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D 5.3 Moving and sizing of dynamic objects

On selecting a dynamic graphic object, a frame appears surrounding it. Just as in the case of
static graphic objects, the dynamic object can be changed in size or moved about.

D 5.4 General parameters for dynamic graphic objects

Six tabs are provided in the parameter dialog for the dynamic graphic objects bar graph, fill area,
alphanumeric display, selection field, graphic symbol and self-animated object; they are
described here for all objects. The parameter dialogs for the graphic objects trend window and
button, button field, and radio button field are described in their own sections.

The general section of the dialog shows both the object name and the object type.

Object name Shows the name of the dynamic graphic object.

Type Shows the type of graphic object
BG = Bar graph, FA = Fill area,
AD = Alphanumeric display, SA = Self-animated object,
GS = Graphic symbol, CUO = Trend window.
SEL = Selection field, BUT = Button,
BTF = Button field, BTR = Radio button,

Process value tab
Details of the process variables that are to be displayed with this graphic object.
Definition of the display of this object in the graphic editor.

Scaling tab
The area to be displayed is defined for an animation with an analog value. The limits are
specified either by constants or by other process variables.
For bar graphs and fill areas, the fill direction and position of the reference line are defined.
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Bit allocation tab
A dynamic object may have up to 3 dynamic process states assigned to it. These binary values
are linked in DigiVis bit-wise, so that the object can be displayed in up to 8 states.
There are two options for defining a binary process state:
• any process value whose data type is BOOL
• existing messages

Display tab
Up to 8 object display states are defined for DigiVis, corresponding to the binary process
values.

General tab
Static objects can be configured specifically as foreground or background objects for the
dynamic object.
When a dynamic object in DigiVis is clicked on, this can also be used to trigger an action, e.g. a
change of display or the writing of a process variable.

Positions tab
A graphic symbol can be either moved continuously across an area in the graphic display or
displayed at up to 8 chosen positions in the graphic display. This area or these positions are
defined on this tab.
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D 5.5 Process value tab

Display variable
Input field Enter the name of a process variable or select from list via F2 key.

Message text In place of a process value, the specified text of a message will be
displayed.

Checking this box will make the MESSAGE button available. The input field
will be colored gray and the text <Message text> displayed.
(Only available for alphanumeric display graphic objects.)

MESSAGE Choice of the message point, the text of which is to be displayed in the
alphanumeric display.
(Only available with alphanumeric display graphic objects)

Display value (GED) On quitting the parameters mask, the graphic object is displayed on the
screen as it is to appear with the value specified. An arrow in the graphic
object indicates that the scaling has been violated.

tu0900us.bmp

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-29

D 5.6 Scaling tab

The scaling of the display, the fill direction and the position of the reference line are specified in
this parameter dialog.

Scaling
Start/End The display range (0 – 100%) can either be specified by giving a constant

or as a variable name (selection list available with F2).

Filling
Horizontal/Vertical Direction in which the dynamic graphic object is to be filled.

Reference line (%) The reference line of the bar graph is given in percent; it defines the value
0 in the bar graph drawing area or the fill area.
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D 5.7 Bit allocation tab

Dynamic objects of type bar graph, alphanumeric display, fill area and graphic symbol may
have up to 3 dynamic process states assigned to them. These binary values are linked in
DigiVis bit-wise, so that the object can be displayed in up to 8 states.
There are two options for defining a binary process state:
• any process value whose data type is BOOL
• existing messages

Variable/Function
Bit1, Bit2, Bit3: Either a process variable or a set of message points with a select function

can be assigned to each of three bit variables. The number of bit
variables specified will determine the number of graphic object states that
need to be specified.

1 Bit-Variable = 2 states of the dynamic object have to be specified.
2 Bit-Variables = 4 states of the dynamic object have to be specified.
3 Bit-Variables = 8 states of the dynamic object have to be specified.

Data input field: Depends on the state of the Messages check box:
The binary process state is defined by a variable of type BOOL.
Enter the name of a BOOL variable, or select one from the list (call up the
list by pressing the F2 key)

or
The binary process state is defined by a set of message points.
The F2 key calls up a dialog for selecting a message function.
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Messages: A set of message points is used to define a binary process state. If the
check box is selected, the SET button becomes available, and the text
'<all messages>' is displayed.

SET Choose a set of message points from among all existing message points
in the project.

After pressing the F2 key in an input field for a bit variable with messages, an additional dialog
box appears. The choice made there determines which message status will be used for
evaluation.

<active messages> From the set of configured messages, those whose message state is
'active' are evaluated.

<all messages> From the set of configured messages, those whose message state is not
'inactive, acknowledged' are not evaluated, i.e. all active messages and
all the inactive, unacknowledged messages.
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D 5.8 Display tab

Animation of a graphic object with binary process states means that the graphic object will be
displayed with changing graphic attributes. In addition to specifying pre-set colors, it is possible
to configure an object to take on the color of a message (message color is determined by the
message priority).
It is first determined which of a set of messages are active or pending. Then with one of the
functions most important message, newest message, oldest message or highest priority
message exactly one message is singled out. Both the foreground and background color of this
message, each with or without acknowledgment information, can be used for displaying the
object. In DigiVis, the process of singling out a message and updating the graphic object with
the current colors of that message is repeated once per update cycle.

Variables/functions
Bit1, Bit2, Bit3 Display the configured bit variables and functions.

Table
Bits Displays the possible bit combinations of the binary variables.

Status Numbering of the states available for the graphic object.

Display On quitting the parameters mask, the dynamic object is displayed with
the attributes of the selected line in the graphic display.

Msg This button is available when the state of the graphic object is determined
by messages. When it is selected, a dialog appears in which a message
can be singled out.
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Border/Fill color Click mouse on color field or press TAB key repeatedly until focus is on
the color field, then press SPACEBAR.

It is possible to change the border and fill color settings for the dynamic
graphic object. The setting of the desired colors is made out with the color
selection parameter window (see page D-13, Color selection). With the
setting invisible, the border or area is displayed transparent, with Original
colors, the colors of the static graphic object are used.

If the state of the graphic object is influenced by messages, then, in the
second color dialog (MESSAGE COLORS) the object can be configured to
take on colors from the messages it depends on (see below)

DISPLAY Switch to the graphic display. Operative only with certain dynamic graphic
objects.

Object name → Click field → F2 Function key,
→ Outputs the names of the static graphic objects that are not yet in use.
→ Select and OK,
→ Name of selected graphic object is shown in this field.

or

→ Click the desired field under Object name
→ Use DISPLAY to change to the graphic display,
→ Select existing or newly created static graphic object which is not yet
in use
→ Return to parameter definition via → Edit → Return to object
→ Name of the graphic object is entered in the field (If a static graphic
object without a specified name is selected, this object is automatically
assigned a system-generated name.)

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-34

Assignment of a message color to a dynamic graphic object.

Foreground color of message
Background color of message

The color, determined by the priority of the selected message, is used in
displaying the graphic object.

with acknowledgment information
without acknowledgment information

The graphic object will be displayed with blinking or static message color.
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Singling out a message from among the set(s) of configured messages:
After pressing a Msg button in the color table, the following dialog comes up. At run-time,
exactly one message must be singled out in order, for example, to determine the color of a
dynamic graphic object.

In the upper portion of the dialog, the sets of specific message points that are to be used are
specified. In the lower portion of the dialog are the specifications as to which of these
messages is to determine the current object color.

tu0507us.bmp

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-36

most important
message The most important message is determined using the following algorithm:

Criterion A: Message status
Step 1 active, not acknowledged
Step 2 not active, not acknowledged
Step 3 active, acknowledged

All messages being equally important according to Criterion A are sorted
according to:

Criterion B: priority.
Step 1 System messages S1..S3
Step 2 Messages with priority 1
Step 3 Messages with priority 2
Step 4 Messages with priority 3
Step 5 Messages with priority 4
Step 6 Messages with priority 5

All messages being equally important according to Criteria A and B are
sorted according to

Criterion C: Acknowledgment strategy.
Step 1 Acknowledgment strategy 1
Step 2 Acknowledgment strategy 2
Step 3 Acknowledgment strategy 3

From all messages being equally important according to Criteria A, B, and
C the oldest message will be determined.

highest priority message
The message with the highest priority. If more than one message with the
same priority exists, the 'most important' will be determined.

newest message The message with the most recent time stamp. If more than one message
with the same priority exists, the 'most important' will be determined.

oldest message The message with the time stamp furthest in the past. If more than one
message with the same priority exists, the 'most important' will be
determined.
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D 5.9 General tab

OBJ. IN FOREGROUND/
OBJ. IN BACKGROUND Overlapping of static and dynamic graphic objects.

Static graphic objects can be placed in front of or behind dynamic objects.
After pressing one of these two buttons, the corresponding graphic level
is activated. Static graphic objects can be selected or created at that
level. Return to parameter definition is carried out via the menu item Edit /
Return to object. After completion of parameter definition, the edited
graphic objects are grouped, connected with each other (share a common
frame).

Grouped graphic objects can be ungrouped as follows:

→Select dynamic object → Animate → Reedit,
→Select OBJECTS IN FOREGROUND or OBJECTS IN BACKGROUND, graphic level is activated,
→Click on an unoccupied area (no item should be selected),
→ Edit → Return to object....

The connection between the dynamic and static objects is removed.

ACTION When a dynamic graphic object is selected in DigiVis, an action such as a
display change, calling up a tag allocation faceplate, operation of a
variable or acknowledgment of a message can be made to occur. See
following chapter for details on how such an action is configured.

Comment Free-form text can be entered to describe the graphic object (max. 33
characters).
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D 5.10 Configuring an action

An action can be specified for all dynamic graphic object types except trend window. In DigiVis,
this action will be triggered by a single click on the object. An exception is the call-up of a tag
allocation faceplate: the tag is selected with a single click and the associated faceplate is called
up with a double click.

One of the following actions can be configured for any dynamic graphic object:
• Call up a tag allocation faceplate,
• Call up any desired display,
• Write a value to a process variable,
• Acknowledge messages.

→Press ACTION button to bring up the Action parameters window.

Anything entered here will have the effect of clearing any other entries from the dialog box. An
entry can be made directly or a list can be called up with the F2 key.

When setting up parameters for a radio field, entries can be made under
OPERATION only.

Display allocation When the graphic object is selected in DigiVis, the display entered here
will be called up.

Tag allocation When the graphic object is selected in DigiVis, the faceplate associated
with the tag entered here will be called up.

Write variable When the graphic object is selected in DigiVis, the current value of Value
will be written to the variable entered here.
Entering the name of a variable in this field enables the Operation button.
See page D-40, 'Write variable' operation.

Acknowledge When the graphic object is selected in DigiVis, an acknowledge message
is sent to the messages specified here.
Selecting one of the message functions from the selection box enables
the MESSAGES button. See page D-44, Selection of messages.
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D 5.11 Acknowledgment of messages

DigiVis can be made to acknowledge messages when an object is selected.

It is possible to so configure a dynamic object, that when it is selected in DigiVis,
messages which are not visible in the display will be acknowledged.

Acknowledgment messages are only sent to message points for which an entry in the message
page is available. Which of the specified message points are to be acknowledged when the
graphic object is selected, must be specified with the acknowledgment function.

From all message points configured under MESSAGES are acknowledged:
all messages all message points.

most important The most important unacknowledged message is determined using the
message following algorithm :

Criterion A: Message status
Step 1 active, not acknowledged
Step 2 not active, not acknowledged
Step 3 active, acknowledged

All messages being equally important according to Criterion A are sorted
according to:

Criterion B: priority.
Step 1 System messages S1..S3
Step 2 Messages with priority 1
Step 3 Messages with priority 2
Step 4 Messages with priority 3
Step 5 Messages with priority 4
Step 6 Messages with priority 5
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All messages being equally important according to Criteria A and B are
sorted according to

Criterion C: Acknowledgment strategy.
Step 1 Acknowledgment strategy 1
Step 2 Acknowledgment strategy 2
Step 3 Acknowledgment strategy 3

From all messages being equally important according to Criteria A, B, and
C the oldest message will be determined.

highest priority message
The message with the highest priority. If more than one message with the
same priority exists, the 'most important' will be determined.

newest message The message with the most recent time stamp. If more than one message
with the same priority exists, the 'most important' will be determined.

oldest message The unacknowledged message with the time stamp furthest in the past. If
more than one message with the same priority exists, the 'most important'
will be determined.

D 5.12 'Write variable' operation

After a process variable is specified for writing to by a DigiVis operation action, the type of
operation and associated operations log entry format must be specified. The value to be written
to the variable is either fixed as a configuration setting or to be entered by the DigiVis user. The
same dialogs are available for user entry of a value as are used for operating a tag allocation
faceplate:
• Values for variable of all data types except BOOL can be obtained with an input field or a

scroll bar.
• Values for all data types except REAL can be obtained from the user with fields of up to 6

radio buttons.

Values for structured variables can also be obtained via a graphic display. The operation of
each component of a structured variable is configured separately. In DigiVis the operation of
the components is carried out one after another. Not all components need participate in the
operation procedure.

After a graphic object is selected in DigiVis, a dialog is displayed on the bottom of the screen.
When the operation dialog is called up, the current value of the process variable to operate is
read and displayed as default value. For a description of the DigiVis user input dialog, see the
Operators Manual, Operator Station, Operating Philosophy.

Only one operation procedure can be configured on a graphic display for a given process
variable. It is not possible, for example, to configure one graphic object with an input field and
another graphic object with radio buttons to operate the same variable in the same graphic
display.
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It is possible, however, to configure a variable to receive a value from the user via one graphic
object and to receive a fixed, preconfigured value via another graphic object.

The mask which appears when OPERATION is chosen for configuring the writing to a process
variable, depends on the data type of the variable.

Configuring operation of a REAL variable

Variable Shows the name of the associated process variable.

fix/operate Choose whether the variable is to receive a fixed value or a value
obtained from the DigiVis user. If fix is selected, entries may be made
in the Text for variable, Dimension, Fixed value and Lock fields.

When setting up parameters for a radio field, entries can be made only for
fixed values.

Type Shows the data type of the variable.

tu0580us.bmp
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Component For structured data types only.
One element of the structured variable is selected at a time from the
selection list. The operation of each component is configured separately.
In DigiVis the operation of the components is carried out one after
another.

write/don’t
write component For structured data types only.

Whether or not it shall be possible to operate a component in DigiVis is
specified here for each component..

Text for variable Input any text.
This text will be displayed in the operation dialog in front of the input field
or radio buttons and used as variable name in the operations log.

Dimension Input any text.
This text will appear after the input field in the operation dialog, and after
the old and new values in the operations log.

Fixed value Input is only possible here if fix operation has been chosen. DigiVis will
write this value directly to the process station without bringing up any
operation dialog.

continuous DigiVis will obtain the value using an input field and scroll bar..

discrete Up to 6 radio buttons will be used by DigiVis to obtain the value in a
dialog box..

Min/Max Value range for the scroll bar. If no range is configured, the scroll bar will
not be available for input.

Lock The operation of a value can be locked in conjunction with a BOOL
variable. When the operation dialog is called up, this variable is first read
and operation refused if it has a value of TRUE. Also, writing a fixed value
can be prevented by the configuration of a Lock variable.

negate The value of the variable defined in Lock is negated for the purposes of
locking out operation, i.e. to lock out operation, the variable must have a
value of FALSE.
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Configuring operation of a BYTE variable

To operate a variable with the help of radio buttons, after selecting discrete, configure up to 6
radio buttons.

Value Value (must be compatible with data type of the variable to be operated).
When the dialog box is called up, the variable to be operated will be read.
The radio button whose configured value agrees with the variables
current value will be displayed as selected.
When DigiVis initiates the write action, the value that was configured for
the radio button that is selected will be written to the variable.

Text Input any text.
This text will be displayed in the operation dialog behind of the radio
buttons and used as ”value” in the operations log.

Lock The operation of an individual radio button can be locked In conjunction
with a BOOL variable. When the operation dialog is called up, this
variable is first read and the radio button displayed as unavailable if the
variable has a value of TRUE.

tu0581us.bmp
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negate The value of the variable defined in Lock is negated for the purposes of
locking out operation of a radio button, i.e. to lock out operation of the
radio button, the variable must have a value of FALSE.

Dimension In the operation dialog and the operating protocol the process variable
values are displayed with the texts assigned in the column Text.

(e.g.: ‘Variable speed: fast --> slow)
If the operated variable has an old value that is not part of the set of
configured values, the operating protocol represents both the old value
and the new value with its numerical value and additional the configured
dimension.

(e.g.: ‘Variable speed: 40 --> 20 m/s)

D 5.13 Selection of messages

All allocated tags in the project that have a faceplate and at least one message point are listed.
Using the buttons in the column headings, the list can be sorted by different entries. Search
criteria can be entered in the input fields above the list (see also Engineering Manual, IEC
61131-3 Programming, Tags).

Each line in the list is provided with a checkbox in which to mark the chosen message points.

Search criteria input fields:
Tag Tag name; ‘*’ and ‘?’ may be used as wildcards.

Area Plant area, select from a list with all used areas of the project.

tu0504us.bmp
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Access by client The name of a gateway or operator station can be given as a search
criterion, i.e. only the tags available on this station are listed.

Type name Function block type

L Library type

Show message points Every message point of the listed tag is shown on a line of its own.

Column labels:
Tag Tag name

Type name Type of function block

L Type of library
(S: Standard, U: User defined, E: Special)

A Plant area

MP Message points

P Message priority

Message Configured message text

Type Message type

SEARCH The list is redrawn, taking any entries in the search criteria fields into
account.

SELECT ALL All message points in the list are selected.
The selections remain even after entry of new search criteria provides a
new list of message points.

UNSELECT ALL The selection of all message points is undone. This procedure is
independent of the search criteria in effect and the contents of the
displayed list.

SELECT MARKED ITEMS

All message points with marked checkboxes are selected.

UNSELECT MARKED ITEMS

All message points with marked checkboxes are unselected.
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D 5.14 Positions tab (only for graphic symbol)

continuous
x-, y- coordinates Enter the x/y coordinates of max. movement. The movement range is

produced from the process variable and the scaling. The movement
vector set determines the movement of the graphic symbol when the
value of the variable is equal to the end of the scale. When the variable
value is equal to the start of the scale, the graphic symbol is displayed in
the design position.

→ click on x- or y- field,
→ switch to the graphic display via the DISPLAY button,
→ Determine position with cursor.

DISPLAY Switch to graphic display,
Return via → Return automatically to parameter definition following 2
mouse clicks.

Discrete
ALL POSITIONS Enter all positions

→ Change to the graphic display via the ALL POSITIONS button,
→ Click positions, → Automatic return to the parameter screen,
→ Coordinates are entered.

SINGLE POS. Enter single position

→ Select x- or y- field, → Enter the x/y-position or
→ Change to the graphic display via the SINGLE POS button.,
→ Click on desired position, automatic return to the parameter screen,
→ Coordinates are entered.
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D 5.15 Bar graph

→Animate → Bar graph
→A mouse-click fixes the position of the top left-hand corner; by moving the mouse, the

size of the bar graph can be adjusted. Another click of the mouse at this point
concludes the construction of the bar graph,

→Enter data in the parameter mask,
→Display the bar graph without construction frame.

A current process value can be displayed as a rectangular column. The
minimum and maximum values of the column can be given as constants or
as other process values. The column can be filled vertically or horizontally.
The reference line of the bar graph is given in percent; it defines the value 0
in the bargraph draw area.

The line style, line width, pattern and colors for the background are defined
with:

→Change → Line attributes/Area attributes or via the toolbox with the
LINE or AREA Buttons,.

The color settings for the border and the areas are made in the color table
parameter windows (see page D-13, Color selection). The colors can be
made to change as a function of binary variables and/or messages.

A bar graph is configured using the parameters on the Process value, Scaling, Bit allocation,
Display and General tabs.
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D 5.16 Fill area

→Animate → Fill area
→Enter data in the parameter mask,
→From the color table mask, select DISPLAY to switch to the graphic display,
→Select an existing polygon or create a new one,
→Edit → Return to object → OK.

A fill area is linked to a polygon. The area bounded by the polygon is filled
as a function of a current process value. Minimum and maximum values
associated with the fill area are set as constants or configured as other
process values. The area can be filled vertically or horizontally. The fill area
reference line is given in percent.

The line style, line width, pattern and colors for the background are specified
with:

→Change → Line attributes/Area attributes, or via the toolbox with
the LINE or AREA button.

The color settings for the borders and the flooded area are made in the color
selection parameter windows (see page D-13, Color selection). The colors
can be made to change as a function of binary variables and/or messages.

The static object polygon can no longer be selected individually, but only as a fill area.
Assigning a different polygon to a given fill area makes the previously assigned polygon
available again as static graphic object.

A fill area is configured using the parameters on the Process value, Scaling, Bit allocation,
Display and General tabs.

Description of parameters specific to fill areas

Display

DISPLAY The switch to the graphic display is compulsory. An existing polygon can
be selected or a new one created. Return to the parameter mask via →
Edit → Return to object.
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D 5.17 Alphanumeric display

→Animate → Alphanumeric display
→A mouse-click fixes the position of the top left-hand corner and, by moving the mouse,

the size of the alphanumeric display can be adjusted. Another click of the mouse at
this point concludes the construction of the alphanumeric display,

→Enter data in the parameter mask,
→Display the text without construction frame.

The current contents of a process value will be displayed either numerically
or as text in any format desired. All system data types can be represented.
Even the display of a configured message can be realized with an
alphanumeric display.

The size, alignment and the fix point can be set with

→Change → Text attributes or via the toolbox with the LINE or FIELD

button.

The foreground and background color settings for texts are made in the color
selection parameter windows (see page D-13, Color selection). Both the
colors and the display format of the current variable can be made to change
as a function of binary variables and/or messages.

An alphanumeric display is configured using the parameters on the Process value, Bit allocation,
Display and General tabs.

Description of parameters specific to alphanumeric displays

Display
Format A separate format can be specified for each of the up to 8 states that the

alphanumeric display can assume.

→ Click on format area → Press F2 Function key
→ Select format → OK.

A window is opened, and the various output formats are presented for
selection, including formats conforming to the IEC Standard. Custom
formats can also be created. For details see Select and create custom
formats at the end of this parameter description.
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Select and create custom formats

After selecting the table column Format on the Display tab and pressing F2, the Select Format
window shows the standard default data formats for the relevant data type. The desired format
can be selected, then accepted with OK.

Format
fixed Standard formats for the data type; the ADD, EDIT and DELETE buttons

are disabled.

user defined Display custom formats; the ADD, EDIT and DELETE buttons are
available.

With the settings fixed and user defined one can switch between the format displays. In the
user defined display mode, a new format can be specified using the ADD button. A selected
format can be deleted with the DELETE button or be called up via the EDIT button and changed
in another window.
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Name Name of the new format

Format Desired formatting. Use the letter f, for example ff.ffff for two places in
front of the decimal point and four places after the decimal point.
'-' serves as a wild card for negative numbers, and a display with a
leading sign is indicated by '+'.

OK Adds the new format to the existing format list.

Examples of fixed data formats:

One Standard format is available for each data type, see table:

The following applies to the representation of REAL numbers: Due to internal
representation constraints, conversion of real numbers to displayable values cannot be
made to more than 7 significant digits. Because of this fact, in the standard format, the
number of decimal places is adjusted as a function of the numeric value. Very large and
very small values are displayed in exponential notation.

Data type Name Format Example
REAL Float +f.ffffffE+ee -4.670000E-19

Fixed point 1 f.f 3.1
Fixed point 2 f.ff 3.14
Fixed point 3 f.fff 3.141
Fixed point 4 f.fff 3.1415

BOOL BOOL (= Standard) b TRUE
Decimal +fff 1

INT, UINT, Binary 2#ffffff 2#101010
DINT, UDINT Octal 8#ffffff 8#605301
BYTE, Decimal (= Standard) +fff -145
WORD, WORD Hexadecimal 16#ffff #16#F90C

TIME Duration (= Standard) T#fhffmffsffms T#1h35m50s8ms
hh:mm:ss.sss hh:mm:ss.sss 15:36:55:041
hh:mmm hh:mmm 15:36
ss.sss ss.sss 55.041

DT Time of day
(=Standard)

DT#yyyy-mm-dd-
hh:mm:ss,sss

1998-09-15-14:36:55,041

Summertime /
wintertime (*)

DT#yyyy-mm-dd-
hh:mm:ss,sss a

1998-09-15-15:36:55,041S

hh:mm:ss.sssa (*) hh:mm:ss.sssa 15:36:55.041S
hh:mm:ss.sss hh:mm:ss.sss 14:36:55.041
dd-mm-yy dd-mm-yy 15-09-98

STRING Pure string s:0:0:n,n ABCDEFG
12345

String (= Standard) s:0:0:y,y 'ABCDEFG$N12345'

(*) If the time to display is in summertime, the value is increased by the summertime differential and flagged with , (both

in DigiVis and in the graphic editor).

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-52

Examples of user defined data formats:

Data type Format Example
REAL [+|-| ]f.ff...{E[+|-]ee} 3.141E+00, 3.0, -4.2, +6.2E-05
INT, UINT, DINT, UDINT [+|-]fff... 35, 4000, +500
BYTE, WORD, DWORD 0f 07

TIME see fixed data format

DT see fixed data format
STRING types s:L{,S}:Z:I:T High, Low

Control characters for use with strings:

. Number of displayed characters. Default: all
S: Position of the first character to be displayed. Default: 0

Character 1 occupies position 0.
Z: Line to be displayed, for all lines enter 0. Default: 0
I: Display of control characters and margin delimiters;

Options y or n. Default: y
T: Interpret tab signs, options y or n. Default: n

Control characters:

$R Carriage Return (CR),
$N Line Feed (LF),
$L Carriage Return and Line Feed ($R$N),
$T Tab,
$ff Hex-coded ASCII character (e.g. '$41' for 'A'),
$' Apostrophe (‘)
$$ Dollar sign ($).
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Example:

Format STRING variable Output STRING variable
s: 'ABCDEFG$N12345' 'ABCDEFG$N12345'
s:11 'ABCDEFG$N12345' 'ABCDEFG$N
s:10,5 'ABCDEFG$N12345' EFG$N1234
s::2 'ABCDEFG$N12345' 12345'
s:2,1 'ABCDEFG$N12345' A
s:2,1:2 'ABCDEFG$N12345' 2
s:2,0:2 'ABCDEFG$N12345' 1
s:::n 'ABCDEFG$N12345' ABCDEFG12345

s:10 'ABCDEFG$N12345'
: :
0 9

and one space 'ABCDEFG$

s:10,5 'ABCDEFG$N12345'
: : : :
0 4 : :

5 :
0 8

and one space EFG$N1234
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D 5.18 Graphic symbol

A graphic symbol is used to animate static graphic objects. As with the other dynamic objects,
a maximum of 3 binary process states, and consequently eight different states can be
configured for this object. Two colors and one static object are defined for each state. The
static objects can be single objects or groups containing several objects (SGM). It is thus
possible, for example, to display a line in a variety of different colors and also to select
completely different representations for the various different states

The following Animate options are available:

• Do not move
Display with or without color change at the same coordinates as a
function of binary variables.

• Discrete move
The pre-set coordinates at which the graphic symbol is displayed are
a lookup function of binary variables (max. 3). Customized colors can
also be specified for the different states (maximum of 8).

• Continuous move
The graphic symbol is moved continuously between two x/y
coordinate points as a function of an analog signal. Up to 3 binary
variables can also be set in order to define a maximum of 8 different
color- and display states for the graphic symbol.

When a graphic symbol is moved, all associated items are always moved together.

→Animate → Graphic symbol
→Fill in the parameter masks,
→Select DISPLAY or type F2 in the color table mask,
→Select or create graphic objects in the graphic display or select graphic object from the

list,
→Return to parameters via → Edit → Return to object → OK.

A graphic symbol is configured using the parameters on the General, Bit allocation and Display
tabs. Depending on the animation type, parameters on the Process value, Scaling and Position
tabs may also need to be defined.
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Color table

By configuring a maximum of 3 binary variables, the graphic symbol can be displayed in up to 8
states. For each of these states, a static graphic object and a color combination is specified
(see also Page D-32, Display tab)

Object name → Click field → F2 Function key,
→ Outputs the names of the static graphic objects that are not yet in use.
→ Select and OK,
→ Name of selected graphic object is shown in this field.

or

→ Click the desired field under Object name
→ Use DISPLAY to change to the graphic display,
→ Select existing or newly created static graphic object which is not yet

in use
→ Return to parameter definition via → Edit → Return to object
→ Name of the graphic object is entered in the field (If a static graphic

object without a specified name is selected, this object is automatically
assigned a system-generated name.)

D 5.19 Self-animated object

→Animate → Self-animated object
→Fill out the parameter-definition masks,
→Press the DISPLAY button in the color table mask,
→Select or create graphic objects in the graphic display,
→Return to parameter mask via → Animate → Return to dynamic object,
→OK.

Up to 8 static graphic objects will be displayed in turn for 125 or 250 ms each.

When a graphic symbol is moved, all associated elements are moved together.
If the View all box is ticked in the Display parameters mask, all the elements of the selected
object that are being used will appear in the display, and—when selected—will be surrounded
by a construction frame.

A self-animated object is configured using the parameters on the Bit allocation, Display and
General tabs.
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Description of defining parameters specific to self-animated objects

The variables have different meanings in the bit variables dialog.

Visible/Invisible Depending on the value of a process variable, the graphic object is either
shown or not shown in the graphic display sequence.

On/Off Depending on the value of a process variable the intermittent display of
static objects is switched either on or off.

Fast/Slow The speed of animation is made to change with the value of a process
variable.

Display

Up to 8 static objects and color combinations can be assigned to a self-animated object.
Depending on the values of the specified process variables, the next object appears in the
graphic display every 125 or 250 ms, the animation is started or stopped, or display of a given
object is included or not.

D 5.20 Trend window

→Animate → Trend window,
→Upper left corner of the Trend window is positioned with a mouse click,
→Define Trend window size by moving the mouse, terminate by clicking mouse,
→Enter data in the parameter mask,
→Display Trend window with a frame.

Display up to 6 trends within a trend window.

A Trend window can be positioned and sized at will within a
graphic display. Up to 6 trends may be displayed in one
window. These trends have no history, i.e. display of the
measured values commences when the corresponding graphic
is called up. The color can be set separately for each trend, as
it can for the Trend window foreground and background.
Standard scaling is specified but can be changed within
DigiVis.

The Trend window can be shown with or without 3-D formatting.
The trend data are captured according to the cycle time defined for the graphic. A max.
recording time can be set in TIME format.
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The Trend window cannot be moved in DigiVis.
No trends can be added in DigiVis.

Trend window parameters

Trends List of variables specified for display in the Trend window.

INSERT On selecting the INSERT button, the Trend data window appears, where
the trend variable can be entered with its characteristics.

EDIT On selecting a specified variable (click on variable under Trends) and
pressing the EDIT button, the Trend data window appears with the
entries for that trend variable. The entries can be changed in this window.

DELETE On selecting a specified variable (click on variable under Trends) and
pressing the DELETE button, the variable is deleted from the Trend
window.
The display of the scaling axis on the left is determined by the settings for
the variable selected when exiting this dialog box.
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Time axis
Max. duration Specify the max. duration for which the trend can be captured without

leaving this graphic display Thereafter each new value overwrites the
earliest value. Entry is in TIME format (max. approx. value depends on
cycle time of the display, e.g. for a graphic display with cycle time of 1s
the max. duration of each trend window is about 2h16m ).

Standard duration Specify the visible time range in the Trend window. Entry is in TIME
format (max. approx. 24 days).

Colors
Background Specify the background color of the Trend window.

Foreground Specify the foreground color (scaling, raster) of the Trend window.

Window Specify Trend area color for the Trend window.
Click on color field and color selection via the Color Selection parameter
window (see page D-13). Select color and confirm with OK.
Selected color is shown in the color field.

Display Depiction of Trend window in the graphic display

3D Trend window in 3-D format
Trend window without 3-D format,

Scale below The time axis is displayed under the Trend window,
Trend window displayed without time axis,

Scale left Scaling is displayed in physical dimensions to the left of the Trend
window. The scaling values used are those which were configured for
the variable selected in the trends list upon exiting this dialog box.
Trend window without left scaling,

Scale right Scaling is displayed as percentage to the right of the Trend window,
Trend window without right scaling.
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Trend window variables parameter

Insert new Trend window variable

→Press the INSERT button in the Trend window.

Change existing trend variable

→Select a specified variable,
→Press the EDIT button in the Trend window.

Variable Enter trend variable directly or select via F2 function key.

Comment A comment with up to 19 characters may be entered; it will be displayed
to the left of the scaling and be visible only if Scale left is selected. (The
size of the trend window within the graphic display is defined by the
maximum length of the comments for all entered variables.)

Tag allocation Enter the name of a tag. It will be possible to call up this tag directly in
DigiVis via the Trend window. Enter the tag name directly or select via F2
function key.

Value range
Min. Start of scale range, in physical units,
Max. End of scale range, in physical units.

Color Specify trend color for the Trend window. Click on color field and make
color selection via the Color Selection parameter window (see page D-
13). Select color and confirm with OK. Selected color is displayed in the
color field.
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Interpolation Specify trend depiction.

None No interpolation is performed,
Linear Trend is interpolated in a linear fashion,
Stairs Trend is depicted in discrete steps.

Marker Specify depiction of individual measured values.

None Individual measured values are not marked,
Point/Pixels Individual measured values are marked with points,
Rectangle Individual measured values are marked with rectangles.

D 5.21 Selection area

→Animate → Selection area (select field)
→A mouse click fixes the position of the top left-hand corner and, by pulling the

rectangle, the size of the selection area can be specified. Another click of the mouse
at this point concludes the procedure,

→Enter data in the parameter mask,
→Display the select field without frame.

A selection area enables tag faceplates to be called up in graphic displays. It is
also possible to change over into another specific display (graphic, group
display, trend,..) or to write a fixed or operated value to a process variable or to
acknowledge messages. In case of selection the configured action will be
carried out.

The field and the border of the selection area can be displayed visibly and
colored or they can lie transparent underneath other graphic objects.

On selecting the select field in the graphic display, a frame appears. The select
field can then be resized and moved.

A selection field is configured using the parameters on the Display and
General tabs.
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D 5.22 Button, button field, radio button

→Animate → Button, Button field or Radio buttons,
→ Top left-hand corner of the button is positioned with a mouse click,
→Define button size by moving the mouse, finish by clicking mouse button,
→Parameter window entries,
→Display the button with a frame.

These buttons can cause displays or faceplates to be called up, variables to be set to preset
numeric values, messages to be acknowledged or states to be displayed.

All the buttons, button fields and radio button fields can be displayed in a
variety of different formats (rectangle, rectangle with rounded corners, 3D-
rectangle, ellipse).
When a button is configured, either text can be specified for the button or any
static graphic object can be defined as the button symbol. For each separate
button, the text or button symbol, as well as the text and button colors are
specified in the button/radio button configuration. The size, orientation and font for
the text can be set or changed separately from the definition of button parameters
using the text attribute settings.

A button press under DigiVis does not require any additional confirmation, and can
write a process variable or call up a faceplate or display. A button can be linked with
any variable and displayed as either pushed or unpushed, as well as in different
pairs of colors.

A button field consists of one or more buttons with an associated confirm button. When
entering the parameters, the confirm button is always automatically displayed alongside. A
button field can comprise up to 25 separate buttons. The buttons in a button field can be
configured completely independently of one another. By pressing a button under DigiVis, a
value can be entered or a faceplate or display called up. The action is not actually performed
until the confirm button is pressed.

All the keys in a radio button field are linked with the same process variable. A value for this
variable can be pre-set for each key. When one of these keys is pressed under DigiVis, the value
configured is written to the process variable. If the process variable is set to one of the configured
values, this can be displayed on the corresponding key. Radio buttons cannot call up faceplates
or graphics, and do not have a confirm button.

Changing the text attributes of a button, button field or radio buttons:

→ Select button (or button field or radio field),
→ Change → Text attributes or via toolbox → TEXT,
→ Enter or change text displays → accept with OK,
→ Button text appears as it was entered.

di0548.bmp
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D 5.22.1 Set button parameters

Variable The value of this variable will determine the text and color with which the
button is displayed, as defined below.

Value Reference value for determining the display format:
Variable <> Value or Variable = Value.

Button type Display format of the button in the graphic display.
As a rectangle.
As a 3D rectangle
As an ellipse.
As a rectangle with rounded corners.

Variable <> Value When the variable shown has a value different from the reference value,
the button will be displayed with the text, text color and button color
specified here.

Variable = Value When the variable shown is the same as the reference value, the button
will be displayed with the text, text color and button color specified here.
Entries are not accepted here until a variable name and its reference
value have been specified. (Variable, Value).
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Text/Button object Determines whether button text or a graphic object is to be used for
displaying the button, followed by:

Specification of the text to be shown on the button, or

The name of a static graphic object, either entered directly or selected
after switching to the graphic display via DISPLAY.

Color Colors are selected for the border, button background and (if applicable)
for the text via Color selection (see page D-13).

Show pushed Button is shown as pushed.
Button is shown as not pushed.

ACTION Calls up the Action parameters window see page D-38 Configuring an
action
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D 5.22.2 Set parameters for button field

Rows/Columns Number of button rows and columns, max. 5 each.
The button display is modified accordingly.

OK caption/
OK button object Text or graphic object for confirm button (pre-set to OK).

Button Diagrammatic representation of the buttons, excluding the confirm button.
A mouse click on a button opens the window for specifying the button
parameters.

Colors Color definition is relevant to all button texts and the background of all
buttons.

Unmarked/Marked Respective color settings for button texts and buttons when the button is
not selected or selected.
A mouse click on the upper color field selects the text color, and a click on
the lower color field selects the button color, both selections being
performed in the Color Selection parameters window. See page D-13.

Pushed The button is shown as pushed.

Button type Display format of the button in the graphic display.
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D 5.22.3 Set parameters for radio button fields

Variable The process variable associated with all the buttons in the radio button
field. For details of select fields see page D-38, Configuring an action.

Rows/Columns Number of button rows and columns, max. 5 each.
The button display is modified accordingly.

Button Diagrammatic representation of the buttons. A mouse click on a button
opens the window for defining the button parameters. See page D-66,
Set parameters for individual buttons using the button parameters
window and page D-64, Set parameters for button field.

Colors Color definition is relevant to all button texts and the background of all
buttons.

Variable <>Value/Variable = Value
Respective color settings for the buttons and button texts when the value
of the associated variable is different from or the same as the specified
value. A mouse-click on the upper color field selects text color, while a
click on the lower color field selects the button color, both via the color
selection parameters window (see page D-13).

Pushed The button is shown as pushed.
The button is shown as not pushed.

Button type Display format of the button in the graphic display.
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D 5.22.4 Set parameters for individual buttons using the button parameters window

The procedure is basically the same as configuring an individual button (see page D-62) but
the following special considerations must also be taken into account:

Variable Not used for buttons in a button field, but for radio buttons, the
associated variable is shown here.

Value For radio buttons, the reference value of the associated variable is shown
here.

disabled The selected button is removed from the button field, both in terms of
display and function.
The button is displayed in the chosen color and with the text or object
as specified.

ACTION Calls up the Action parameter-definition window. (see page D-38,
Configuring an action)

Variable = Value No function.

D 5.23 List of the dynamic objects in a graphic display

→Animate → Reedit... → display of the object list

The object list is used for displaying all dynamic graphic objects in the current graphic display,
and for selecting one of them. After an object has been selected, it can then be modified using
the appropriate parameter definition dialog.

D 5.24 Reedit

A graphic object must be selected before its parameters can be changed. This can occur in two
ways: select the object in the graphic display and double-click on it, or use the alternative via
the Reedit menu...

→Select dynamic graphic object → Animate → Reedit....

→Animate → Reedit... → Display of the object list

All the dynamic graphic objects are displayed in the object list with their type and name. A
dynamic object that has been previously selected is preselected in the list. After an object has
been selected, clicking on OK or double-clicking on the list entry will call up the parameter
definition mask for the selected object
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D 5.25 Reediting allocated static objects

Static objects that have been allocated to a dynamic object are no longer directly available in
the graphic display. This applies to objects that have been configured as foreground or
background objects as well as to objects used in defining the dynamic object states (graphic
symbol or fill levels). These objects which have already been assigned can be modified through
the following procedure:

→ Click on the graphic symbol and select the Display tab
→ Position the cursor in the field containing the name of the object to be modified.
→ Switch to the graphic display using the Display button

The static object can now be modified using the usual functions.

The graphic editor is still in "Define parameters for a graphic symbol" mode. This mode
can be clearly recognized in the menu: the menu item Back and most of the toolbar
buttons are disabled. This mode must be exited using the menu command Edit / Return
to object.

A corresponding procedure can be used to retrospectively modify foreground and background
objects, and polygon figures that have been assigned to a fill level.

An additional step is required in order to retrospectively modify a message type symbol - the
message type symbol must be detached from the graphic symbol. To avoid losing the
parameters of the graphic symbol in this process, a new static object is defined for the duration
of the editing process.

→Click on the graphic symbol and select the Display tab
→Position the cursor in the edit field containing the name of the object to be modified
→Switch to the graphic display using the DISPLAY button
→Draw any static object
→Return to graphic symbol parameters via Edit / Return to object
→Exit parameter definition for graphic symbol with OK.

The message type symbol can now be modified with the usual functions.

After all the changes have been carried out:

→Click on the graphic symbol and select the Display tab
→Position the cursor in the edit field containing the name of the newly drawn object
→Switch to the graphic display using the DISPLAY button
→Select the modified message type symbol (the newly drawn object will be deselected

at this point)
→Return to graphic symbol parameters via Edit / Return to object
→Exit parameter definition for graphic symbol with OK.

The newly drawn object is now once more freely available, and can be deleted.
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D 6 Macro

Graphic objects can be grouped together and stored as a macro. Macros are available
anywhere in an entire project and can be used as many times as desired in graphic displays.
Subsequent changes to a macro effect all displays in which the macro was used.

A macro consists of any combination of static and dynamic graphic objects. All attributes of the
objects contained in the macro can be defined as macro parameters. Each time a macro is
used, these attributes, which are part of the macro definition are stored; all the values specified
as parameters can be individually adjusted at each instance of the macro’s use.

Macros can be saved in libraries and thus be made available for other projects. Similarly,
macro libraries can be loaded, in order to make one or all of their macros available in the
current project. Library files have the extension .BOL.

During the installation of DigiTool two macro libraries are copied into the directory
<freelance>/macros. The graphics in the standard macro library hb_sym01.bol are described in
After installation of DigiTool this library is found at: <freelance>/macros/hb_sym01.bol
Appendix - Graphics Macro Library, page D-101. The library ufp_sym1.bol contains macros
that simplify the creation of user-defined faceplates; these macros are described in the DigiTool
1 manual, Section H – User-defined function blocks.

D 6.1 Library functions

→ Macro → Library functions...
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Library: Path and filename of the most recently loaded macro library.

Project: In the left portion of the dialog, the graphic macros available in the project
are listed. An icon with red background displayed on top of a macro name
indicates a macro that was used in the project.

Library In the right portion, the contents of the most recently loaded macro library
are listed.

Load A macro library can be loaded from a data carrier. After loading, the macros
in the library are displayed in the right portion of the dialog.

Save After entering a directory and filename all macros listed in the right portion
of the dialog are saved to the data carrier. The dialog display is not
changed.

> All marked graphic macros of the project (left portion of the dialog) are
copied to the library list (right portion).

>> All graphic macros of the project (left portion of the dialog) are copied to the
library list (right portion).

< All marked graphic macros in the library list (right portion of the dialog) are
copied for use in the project (left portion).

<< All graphic macros in the library list (right portion of the dialog) are copied
for use in the project (left portion).

DEL All marked graphic macros are deleted from the list. In the project list, only
macros can be deleted which have not been used in the project.
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D 6.2 Draw macro

→Macro → Draw
A window opens under which macros are defined by name,

→Select macro → OK,
→Position the top left corner of the macro with a mouse-click.

D 6.3 Create macro

→Select one or more graphic objects in the graphic display
→Macro → Create macro...

The list of all macros available in the project will be displayed. The name of the
new macro must be entered in the input field above the list. After entry of a valid
name, the dialog is concluded and the selected objects are displayed with a
common frame. The individual objects are no longer available: they have been
replaced by a macro reference..

D 6.4 Edit macro

→Macro → Edit...

The list of all macros available in the project will be displayed. If a macro had been selected in
the graphic display, then that macro will be shown selected in the list. After a macro is chosen
from the list, the graphic editor is called up in macro edit mode. (macro editor, MED).

The graphic display background will change color and only graphic objects belonging to the
macro will be shown.

All graphic editor functions are available in the macro editor (MED). Any combination of static and
dynamic graphic objects can be added to or deleted from the macro. Similarly, all attribute
changes and animations possible with the graphic editor are also allowed.

D 6.5 Define macro parameters

The parameters of a macro are set with the macro editor (MED). All graphic attributes defined
to be parameters can be adjusted individually in each instance of the macro’s use. All values
which are not defined to be parameters remain the same in all instances and an not be varied.

All animation (display and bit variables) must be defined to be parameters.

→Macro → Parameter...
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In the right portion of the dialog all attributes of all named objects are listed. Dynamic objects
always have names, so their attributes always appear in the list. Static objects whose attributes
are to made adjustable as macro parameters must be given names (Change / Object name
define, see page D-89 Object name define).
Graphic attributes are displayed with the name of the object and a system-assigned designation
for the attribute: <Objectname>.<Attribute designation>.

In the left portion of the dialog, the macro parameters are listed. For each macro parameter, the
object attributes which will take on that parameter value are shown.

NEW PARAMETER A new entry in the left dialog field is created with a standard name. The
standard name can be changed.

DELETE PARAMETER The macro parameter selected in the left dialog field is deleted. The
attributes which were assigned to the deleted parameter are transferred to
the right portion of the dialog.

< A graphic attribute in the right portion of the dialog is assigned to the macro
parameter which is selected in the left portion. The macro parameter data
type is determined when it is assigned its first attribute. Any number of
attributes of the same type can be assigned to a macro parameter.
Attributes which have been assigned to a macro parameter no longer
appear in the right portion of the dialog.

> The assignment of an attribute to a macro parameter is undone. The
attribute selected in the left portion of the dialog is disassociated from the
macro parameter and reappears in the list of attributes in the right portion.
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The following attribute designations are used in the system:

When used in dynamic objects, the designators are extended by sequence numbers (usually 1–8
or for objects in a trend window, 1–6) or, for button fields, <column>_<line>.

Attribute
Designator

Object type Meaning

Action BG, FA, AD, SEL, SA, GS,
BUT, BTF

Action which can be triggered by this object
in DigiVis

Background TXT, AD Text background color

Background color,
Foreground color

PIE, ELP, PLG, REC, BG,
FA, SEL

Fill pattern colors

Bit variable_1..3 BG, FA, AD, SA, GS Bit variables which control attribute changes
in the object

Bordercolor,
Fillcolor

SEL Border and fill color of a select field

Bordercolor_1..2,
Fillcolor_1..2

BUT, BTF, BTR Frame (or text) and background color of
buttons

Bordercolor_1..8,
Fillcolor_1..8

BG, FA, SA, GS Colors determined by the bit variables

Caption TXT, CUO, BUT, BTF,
BTR

Static text, for trend window the graph
labeling

Charactersize TXT, AD, BUT Text size: 8, 12, 20 or 26 point

Faceplate_1..6 CUO Tag faceplates assigned to the curves

Fillpattern PIE, ELP, PLG, REC, BG,
FA, SEL

Fill pattern

Line_end ARC, LIN, PLN, Ending end of line: round or with arrow

Line_rounded ARC, LIN, PLG, PLN,
REC, BG, FA, SEL

Rounding of corners

Line_start ARC, LIN, PLN, Starting end of line: round or with arrow

Linecolor ARC, PIE, ELP, LIN, PLG,
PLN, REC, BG, FA

Line color

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-73

Attribute
Designator

Object type Meaning

Linestyle ARC, PIE, ELP, LIN, PLG,
PLN, REC, BG, FA, SEL

Type of line: solid or dotted,...

Linewidth ARC, PIE, ELP, LIN, PLG,
PLN, REC, BG, FA, SEL

Line width

Max_Duration CUO Maximum trend collection period

Reference BG, FA Bar graph and fill area reference line

Scale_start,
Scale_end

BG, FA, CUO Scale range for object or curve

Std_Duration CUO Trend display period

Text_alignment TXT Text alignment: top pr bottom

Text_bold TXT, AD, BUT Bold text

Text_direction TXT, AD, BUT Text direction: horizontal or vertical

Text_fixpoint TXT, AD, BUT Text justification: start, center, end

Text_italic TXT, AD, BUT Cursive (italic) text

Text_underlined TXT, AD, BUT Underlined text

Textcolor TXT, AD Text color

Trendcolor_1..6 CUO Curve color

Value BUT, BTR Button value: used for state display and, for
radio buttons, as value to be written

Variable BG, FA, AD, BUT, BTR Display variable

Variable_1..6 CUO Variable for trend monitoring

Windowcolor_1..3 CUO Trend window colors;
1: Background color,
2: Grid and labeling color
3: Graph area background color
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D 6.6 Specifying parameters for a macro instance

A macro is inserted into the graphic display with its default settings. All attributes which were
defined in the MED to be parameters can be individually adjusted for each instance of the
macro’s use.
When a macro is selected in the graphic display, all the macro’s parameters and their current
values are listed.

→ Macro → Parameter...

EDIT The selected macro parameter can be specified for the present instance
of the macro. The dialog mask appropriate for this type of parameter is
called up. Only those entries relevant to the specification of the macro
parameter are available. All attributes which were assigned to this macro
parameter in the MED will take on the new parameter value. The new
value will be shown in the list.

D 6.7 Ungroup macro

With a macro selected in the graphic display

→ Edit → Ungroup

will disassociate the macro objects. All elements of the macro will be displayed with their own
construction frames and can be changed individually.
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D 7 Editing and Changing Display Objects

D 7.1 Changing the size of a graphic object

Changing the size without altering the height-to-width ratio

→Select → place cursor arrow on a corner handle,
→Press mouse button and drag,
→Frame gets larger or smaller → Release mouse button,
→Graphic item/symbol is redisplayed.

Changing height or width

→Select → place cursor arrow on an edge-center handle → Press mouse button and
drag,

→Frame gets larger or smaller → Release mouse button,
→Graphic item/symbol is redisplayed.

Each graphic object—-be it a static, dynamic, combined object or a macro—is displayed with its
attributes at its assigned position. When selected, a frame with marks (handles) at the corners
and edge center points surrounds the graphic item. (Exceptions are horizontal or vertical lines, on
which only the two end points are marked). A cursor click outside this rectangle deselects the
graphic object, and a click within the rectangle selects it again. If one clicks one of the corner
handles of the frame, the cursor arrow changes. With the mouse button depressed, the frame can
then be enlarged or reduced while maintaining its height-to-width ratio. After releasing the button,
the graphic object is displayed within the new frame. Clicking on an edge-center handle allows
the height or width of the object to be changed independently.

D 7.2 Move a graphic object

→Select → Cursor arrow into the center → Press mouse button and drag.

After clicking on a graphic object, its frame is displayed. By positioning the cursor inside the frame
and keeping the left-hand mouse button depressed, the cursor changes into a cross. While the
mouse button is depressed, the rectangular outline of the graphic can be moved about the entire
draw area. On releasing the mouse button, the item is redisplayed at the new position.

When moving several graphic objects (see page D-76, Selecting multiple graphic objects), a
common frame surrounds them all. They can then be moved in exactly the same manner as a
single graphic object.
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D 7.3 Selecting multiple graphic objects

→SHIFT + cursor click on each graphic object in turn.

or

→Position cursor outside the graphic objects to be selected,
→With the left mouse button depressed, drag a marking rectangle over the area.

or

→Call shortcut menu with right mouse button
→Select → All / all static objects / all dynamic objects

In order to change attributes of several graphic objects together, it is possible to select various
graphic objects at once. With the SHIFT key depressed, the desired graphic objects can be
clicked. Several graphic objects can also be selected together with a marking rectangle. In doing
so, only those graphic objects are included which lie completely within the marking.

Each graphic object is displayed with its frame. Alterations of the line and area attributes effect all
selected objects.

If several graphic objects have been selected and if one then wants to select a single
one of them, click on the free draw area with the left mouse button (all graphic objects
will be deselected) and proceed as above.

Several objects can be selected and moved together. As a result, it is possible that
individual objects are moved outside of the visible drawing area. If the selection is then
canceled, these objects cannot be selected with the common procedures The plausibility
check generates a message, that the graphic contains objects outside the visible area.
Use the following procedure to delete these objects from the graphic display:

→ Edit → Select all → all objects in the drawing are selected.
→ Deselect all visible objects with SHIFT + left cursor click.
→ Edit → Delete or press DEL to delete all objects not visible in the graphic display.

After all static objects have been selected the display background can be stored as a bitmap in
the clipboard via Display / Export / As bitmap.

In order to achieve the shortest possible display build-up times under DigiVis you are
strongly advised to store and continue using the static part of the display as a bitmap
after the editing is finished. In a new graphic display this bitmap is imported as a
background, and the animation is performed in the foreground of this bitmap.
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D 7.4 Edit

Under Edit are listed the menu items which facilitate the construction and modification of displays.

D 7.4.1 Return to object

→Edit → Return to object...

For some graphic objects (message type symbol, fill area, graphic symbol, self-animated object,
button) there is the possibility of switching to the static graphic section from the parameter masks
during configuration (via DISPLAY). The Return to object menu item must be selected in order to
return to the parameter mask.
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D 7.4.2 Undo

→Edit → Undo

→CTRL+Z

This is a one-level function and undoes the last change made to the graphic object.

D 7.4.3 Repeat

→Edit → Repeat

→F8

The last action can be repeated, e.g. deleting the end point of a polyline or drawing graphic
objects of the same type one after the other, without having to select the type again under Draw.

D 7.4.4 Select single object

→Click graphic object.

→Edit → Select single object,
→Position cursor (with arrow keys) on graphic object,
→Select with SPACEBAR.

If several graphic objects have been selected and one wants to select a single one of
these, then click on the free draw area with the left mouse button (all graphic objects will
be deselected) and proceed as above.

Every graphic object selected is marked by a frame.

D 7.4.5 Select all

→Sweep over the whole drawing area with the left mouse button pressed.

→Edit → Select all.

All graphic objects in the drawing area are displayed with their frames. Alterations of the attributes
effect all graphic objects selected.
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D 7.4.6 Select graphic objects in the background

If the CTRL key is held down and the mouse clicked, all covered graphic items/symbols are
selected in turn and can be edited.

D 7.4.7 Group

→Select static graphic objects → Edit → Group.

→Select static graphic objects → Edit → Group.

Several graphic objects can be grouped to form a new graphic object with a common frame.
Alterations of size, attributes or movement now apply to the newly created graphic object.

No combined graphic objects can be used for the creation of macros. If necessary, a
grouped graphic must be broken down into its elements (Menu item Edit → Ungroup).

D 7.4.8 Ungroup

→Select combined graphic object → Edit → Ungroup.

→Select combined graphic object → Edit → Ungroup.

Grouped graphic objects are dispersed into their individual graphic objects. In doing so, the
common frame disappears and all the components of the combined graphic objects are displayed
separately with their frames.

Macros can also be broken down into their elements with this menu item.

Graphic objects which are connected with one another through animation cannot be
broken down into their elements with this menu item. To separate them, see page D-26,
General parameters for dynamic graphic objects.

D 7.4.9 Cut

→Select one or more graphic objects → Edit → Cut.

→Select one or more graphic objects → CTRL + X.

The selected graphic objects are removed from the draw area and saved in a buffer memory (not
the standard Windows clipboard).
With Paste the saved objects can be reinserted into the graphic one or more times.
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D 7.4.10 Copy

→Select one or more graphic objects → Edit → Copy .

→Select one or more graphic objects → CTRL + C.

The selected graphic objects are copied and saved in a buffer memory (not the standard
Windows clipboard).

With Paste the saved objects can be inserted into the graphic one or more times. The
copied object is copied to match the original and displayed as it was when selected. It
can be moved to any position. See page D-75, Move a graphic object.

D 7.4.11 Paste

→Edit → Paste .

→CTRL + V.

The graphic objects which were saved in the buffer memory (not the standard Windows
clipboard) via a Cut or Copy command can be inserted into the draw area.

Items are inserted at the location from which they were cut or copied.

D 7.4.12 Delete

→Select one or more graphic objects → Edit → Delete .

→Select one or more graphic objects → DELETE.

The selected graphic objects are removed from the draw area.
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D 7.4.13 Duplicate

→Select one or more graphic objects → Edit → Duplicate .

The selected graphic objects are duplicated on the draw area and not saved in the buffer
memory.
The duplicate is displayed slightly offset from the original and is selected. It can then immediately
be positioned as required (see page D-75, Move a graphic object).

D 7.4.14 Rotate

→Select one or more graphic objects → Edit → Rotate .

Each of the selected graphic objects is rotated 90 degrees counterclockwise around the center
point of its frame.
Texts are rotated around their fixed reference points.

D 7.4.15 Mirror

→Select one or more graphic objects → Edit → Mirror → Horizontal or Vertical.

The selected graphic items are mirrored horizontally or vertically, as desired. The imaginary
mirror axis passes through the center point of the surrounding frame.

Texts cannot be mirrored. If text exists in a grouped graphic object, its position is mirrored but not
the text itself.

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-82

D 7.4.16 Overlap

Serves to determine which of superimposed graphic objects lies in the foreground or background.

It should be noted here that in a graphic display under DigiVis, all static items are located in the
background behind any dynamic objects as a result of the cyclical redisplay of those dynamic
objects. There is, however, one exception, as described on page D-37, Objects in
foreground/background

Foreground

→Select graphic object → Edit → Overlap → Foreground .

The selected graphic object is displayed on top of the other graphic objects. It may cover
the other items partly or entirely.

Background

→ Select graphic object → Edit → Overlap → Background.

The selected graphic object is displayed underneath the other graphic items. It may be
partly or completely covered.

In front of symbol

→Select graphic object → Edit → Overlap → In front of symbol,
A small window with OK and CANCEL appears,
→Select the graphic object in front of which the object first selected is to be inserted,
→Accept with OK.
CANCEL can be used to abort the process at any time.

In case of several overlapping graphic objects, the sequence of overlaps can be
specified here.

Behind symbol

→Select graphic object → Edit → Overlap → Behind symbol,
A small window with OK and CANCEL appears,
→Select the graphic object behind which the object first selected is to be inserted
→Accept with OK.
CANCEL can be used to abort the process at any time.

In case of several overlapping graphic objects, the overlap sequence can be specified
here.

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section D Graphic Display

D-83

D 7.4.17 To graphic pool

→Edit → To graphic pool .

→PAGE DOWN.

Switch to graphic pool. If graphic objects are selected, they are also added to the graphic pool,
being inserted at the same location as in the graphic display.

In this process, some graphic objects may be covered up and thus need to be moved.
See page D-75, Move a graphic object.

D 7.4.18 To display

→Edit → To display.

→PAGE UP.

Switch to the graphic display. If graphic objects are selected, they are accepted into the graphic
display and inserted at the same location as in the graphic pool.

In this process, some graphic objects may be covered up and thus need to be moved.
See page D-75, Move a graphic object.

D 7.4.19 Switch contents display/pool

→Edit → Switch contents display/pool.

The entire contents—including background color—of the graphic display and the graphic pool are
exchanged.

D 7.4.20 Insert pool in display

→Edit → Insert pool in display.

The complete display contents of the graphic pool are accepted into the graphic display. The
background color of the graphic display is retained.

In certain cases, graphic objects may be covered up in this process and thus need to be
moved. See page D-75, Move a graphic object.
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D 7.5 Change attributes

The various line, area and text attributes, as well as the text content of the selected graphic
objects can be altered. If similar graphic objects or grouped graphic objects comprised of several
graphic objects of the same type have been selected, then all attributes are changed together. A
general alteration of attributes, however, to effect subsequent graphic objects, must be made via
the toolbox.

Several objects can be selected and moved together. As a result, it is possible that
individual objects are moved outside of the visible drawing area. If the selection is then
canceled, these objects cannot be selected with the common procedures The plausibility
check generates a message, that the graphic contains objects outside the visible area.
Use the following procedure to delete these objects from the graphic display:

→ Edit → Select all → all objects in the drawing are selected.
→ Deselect all visible objects with SHIFT + left cursor click.
→ Edit → Delete or press DEL to delete all objects not visible in the graphic display.

D 7.5.1 Line attributes

→Change → Line attributes

The graphic object line with the attribute invisible is not particularly useful.. It can be
obtained, if required, via → Edit → Select all.

The line attributes of the selected graphic objects are altered in a dialog window.

tu0750us.bmp
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Color The attribute line color applies to all static graphic objects with the
exception of text and bitmaps.
Any of 237 colors or invisible can be selected. See page D-13, Color
selection.

Width The attribute line width applies to all static graphic objects with the
exception of text and bitmaps, and also to the dynamic objects bar graph,
selection field and fill area.
6 width sizes can be selected.
Dimensions like 1P, 5P etc. are abstract and depend on the screen
resolution; they do not refer to pixel size.

Style The attribute line style applies to all static graphic objects with the
exception of text and bitmaps, and also to the dynamic objects bar graph,
selection field and fill level.
Continuous, dashed, dotted, or dash-dotted can be selected.

Line start
Line end The attribute line start/end only applies to the static graphic objects line,

polyline and arc.
An arrow can be selected at the start and/or end.
The size of the arrow depends on the line width.

Rounded corners The attribute rounded corners applies to the static graphic objects
rectangle, polyline and polygon, and to the dynamic objects bar graph,
selection field and fill area.
None, small, medium or large can be selected.

tu0751us.bmp
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D 7.5.2 Area attributes

→Change → Area attributes.

The area attributes apply to the static graphic objects rectangle, polygon, ellipse and circle
segment and to the background of the dynamic graphic objects bar graph and fill area. The
attributes of an area are changed in a dialog window. In the bottom left-hand corner of that
window a preview of the selected area attributes is shown.

Color Any of 237 colors each can be selected for FOREGROUND and
BACKGROUND.
The color settings have no effect with the pattern setting invisible, and the
background color chosen has no effect with a filled pattern.
See page D-13, Color selection.

Pattern Any of 15 patterns or invisible can be selected.
For the pattern black bars, the fill area is displayed in the fill color selected
for the foreground.
For the pattern invisible, the underlying graphic items/symbols are visible.
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D 7.5.3 Points

The construction points of the graphic objects polyline and polygon can be moved or deleted.

Delete

→Select graphic object polyline or polygon,
→Change → Points → Delete
→Click the point to be deleted, the graphic object remains selected and is redisplayed in

the altered form.

Move

→Select graphic object polyline or polygon,
→Change → Points → Move
→Click the point to be moved and move it to the desired position with left mouse button

pressed. (The frame disappears).
→Releasing the left mouse button completes the action. The graphic object remains

selected and is displayed with the shifted points.

D 7.5.4 Text edit

→Change → Text edit.

Selected texts can be altered. An input window with the existing text appears in which text can be
added or deleted. The text attributes are not effected.

If a combined graphic object contains several texts, the texts are presented for modification one
after the other.
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D 7.5.5 Text attributes

→Change → Text attributes.

Text attributes apply to the static graphic object text and to the dynamic objects alphanumeric
display, button, button field and radio button field. The attributes of selected texts can be
changed in a dialog window.

Color Any of 237 colors can be selected for foreground and background. In
addition, invisible may be selected as background.

Size Choice of text size in pixels.

Character font Arial, Courier or MS Sans Serif can be selected

Alignment There is a choice between horizontal and vertical text.

Fix point Point used for positioning a text. It is situated on the frame at the site
specified horizontally at start, middle or end and vertically by—top or
bottom. The Rotate and Horizontal/vertical Alignment functions turn the
text around this point.

The selections Top and Bottom are only available for object text.
Start left frame edge
Middle horizontal center of frame
End right frame edge
Top upper frame edge
Bottom lower frame edge.

Character attribute Additional choice for text output between Bold, Cursive (italics) and
Underlined.
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D 7.5.6 Object name define

→Select graphic object,
→Change → Object name define...

A name must be unique in a graphic display.

Graphic objects can be provided with names (max. 12 characters). Using these names for the
dynamic or graphic symbols they can be moved, shifted or exchanged. If a name has already
been assigned to the selected graphic object, that name will be displayed and can be changed.

D 7.5.7 Background color

See page D-13, Background color.
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D 8 Display Options for Graphics in the Draw Area

Under the View menu are the various options relating to viewing graphics on the screen.

D 8.1 View

→View → View display,
→Displays the graphic with no grid, no toolbox and no frame. Most of the menu choices

are disabled.

To return for further editing,
→View → View display,
→Display the graphic and enable the menus prior to quitting; or click mouse within the

draw area.

→SPACEBAR (causes immediate changeover).

View allows the graphic currently being created to be viewed at zoom level 1 (full display) and
without the distraction of the editing tools (snap, frame, toolbox). In this state most of the menu
functions are disabled. Selection from menu or pressing the SPACEBAR once returns to a state in
which editing can be performed.
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D 8.2 Simulation

→View → Simulation
→Switch simulation on or off and select the simulation speed.
→All self-animated graphic objects are shown in the graphic display with the chosen

simulation attributes.

When in View the simulation attributes come into play for all self-animated objects; when the
graphic editor is in View the simulation attributes can also be modified.

D 8.3 Redraw

→View → Redraw
→Graphic is redisplayed on the screen with no change to the zoom level.

The graphic is reconstructed. This is necessary, if the current display of the graphic on the screen
does not correspond to the real graphic (parts of the frame may, for example, have been left
behind).

D 8.4 Zoom

→View → Zoom
→Select zoom level 1 to 4 or Overview
→Display the graphic with a dashed rectangle
→Use the mouse to move the rectangle over the desired region of the graphic
→Click mouse, and that region will be displayed at the selected zoom level

A graphic display is usually displayed with Zoom switched off (Zoom 1-fold) as a whole graphic in
the draw area. For easier editing it is possible to display a section of the graphic with 2-, 3- or 4-
fold enlargement. The selected zoom level is indicated in the toolbox under DISPLAY. After
selection of the zoom level the whole graphic display is shown, and a dashed rectangle
superimposed for selecting the desired visible region.

With Visible region or a right mouse-click it is possible to display a different region of the screen.

The Overview function shows an area corresponding to 9 x the drawing size. The actual
drawing area is displayed in the center and is marked with a border. This function enables
objects located completely or partially outside the applicable draw area to be displayed and
identified.
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D 8.5 Visible region

→View → Select visible region
→Graphic is displayed with a dashed rectangle,
→Use mouse to move rectangle and position it over the desired region,
→Click mouse to display this region with the selected zoom level.

→Click right mouse button
→Graphic is displayed with a dashed rectangle,
→Use mouse to move rectangle and position it over the desired region,
→Click mouse to display this region with the selected zoom level.

→View → Select visible region
→Position cursor within the visible draw field,
→Press CTRL + ARROW KEYS → SPACEBAR

→The displayed graphic is moved a fixed distance in the direction of the arrow,
depending on the zoom level selected, and is redrawn.

In order to select a display region (for zoom level > 1), Select visible region makes a rectangle
appear in the draw field . This rectangle can be moved around the draw area and, following a
mouse click or a press of the SPACEBAR, the area located underneath it will be displayed enlarged
by the selected zoom level.
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D 9 General Processing Functions

All functions necessary for the general handling of graphics are located under the Display menu.

D 9.1 Save

→Display → Save...

Save graphics is either carried out explicitly with Save or at a prompt when quitting the graphic
display. During the creation of a graphic display it is advisable to occasionally save in order to
keep data loss as low as possible in the event of any unexpected problems with the PC. The
buffer display is always saved automatically as well.

D 9.2 Check

→Display → Check.

The entire graphic display with its static and dynamic graphic items, macros and parameter inputs
undergoes a plausibility check for errors, missing inputs or contradictions. Any errors are listed in
a window and must be remedied afterwards. A listed error message from the plausibility check
can be selected with a double-click on the message or by pressing the relevant screen button.
Either of these actions has the effect of selecting the appropriate graphic object for editing.
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D 9.3 Export to a file

→Display → Export → To file...,
→Specify file type: Freelance 2000 metafile or Bitmap file
→Enter filename and path → OK.

Individual graphic displays can be exchanged between different projects via files. A file is
created with Export. After invoking Export a window is opened in which the filename and path
should be entered. A choice of export data type between the Freelance 2000 readable file
format with extension ”DMF” and a bitmap file with extension ”BMP” can be made.

D 9.4 Export to clipboard as a bitmap

→Display → Export → As bitmap to clipboard,

The graphic display is saved on the Windows clipboard as a bitmap, and is thus available for
further processing by other Windows applications.

If graphic objects are selected, these are saved as a bitmap; if no object is selected the
complete graphic display is saved.

D 9.5 Import

→Display → Import,
→Enter path and filename with extension, .DMF or .DXF
→OK, graphic display is loaded.

To import a Freelance 2000 graphic file (extension .DMF) created under Export or a file created
in AutoCAD (extension .DXF) into a project, Import must be selected. After selection, a window
is opened, where the path must be entered and the filename entered or selected. The
corresponding graphic display is loaded and shown.

An import file can be imported only into a blank graphic display.
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D 9.5.1 Instructions for loading AutoCAD files

Graphic files created with AutoCAD are in Data Exchange Format (.DXF) and can be converted
automatically into Freelance 2000 Metafile Format (.DMF)

To be convertible, the AutoCAD version must be Release 10 or 11.

The following items from the full range supported by the AutoCAD language can be converted:

Line Period Circle Arc String
Solid Text Polyline Block (Macros)

Shapes, polynets defined with the polyline item, B-Splines and 3D-Polylines, 3D-Face
and viewport items are not convertible.

The DXF script size (font size) is converted according to the DMF coordinate size. The
resultant script size is compared with the displayable script sizes defined in DigiTool and
assigned to the size most closely matching the size to be converted. ”RefPoint, Start” is
assigned with the DMF text attributes to the DXF text attributes ”Aligned” and ”Adapt”.

Only text with rotation angles of 0, 90, 180 and 270 degrees can be converted properly; the
closest angle is assigned in all other cases.
All AutoCAD elements are converted irrespective of their assigned layer. Individual layers
cannot be blanked out.
Blocks that are rotated or reflected are not converted properly.
Instance Objects (SECTION ENTITIES) of any type showing negative coordinates, are not
converted. An exception here is the element objects of a block.
User Coordinate Systems (UCS), external references (XREF) and nested blocks (Insert
instruction in block) are not supported.

During conversion, a log file with the file name DXF2DMF.LOG is created or updated.
Non-convertible elements, non-supported objects and conversion errors are logged in
this file. The path name of the DXF source and the line number within the DXF file are
recorded, followed by an error description text.
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D 9.5.2 Color conversion of AutoCAD files

In order to map AutoCad colors to Freelance 2000 colors a color conversion table—which can,
if necessary, be changed—is entered in the Windows registry editor under the
[ACADCOLORS] entry.
If no such entry exists, a standard conversion table is used which assigns only the AutoCAD
color numbers 1-8 to the corresponding DMF color numbers. In this case, the DMF color black
is assigned to the AutoCAD colors number 9 to 255.
Whether the [ACADCOLORS] entry is used, depends on whether the color setting in the main
menu of DigiTool Options / Color table /is set to Compatible (to Version 2) or Standard (new
color table for Version 3.3).
The conversion tables consist of two components. The first, Table Entries, denotes the
number of color assignment entries to follow in the conversion table. The color assignment
entries have the following format:

colxx=lacadcolor,hacadcolor,dmfcolor
where:

xx Index of the entry in the color assignment table; must be smaller than the
TableEntries entry.

lacadcolor Lower AutoCAD color number of the range to which the DMF color
number is assigned. The lower limit is included in the range.

hacadcolor Upper AutoCAD color number of the range to which the DMF color
number is assigned. The upper limit is included in the range.

dmfcolor Assigned DMF color number.

The following must be noted when changing the color assignment entries:
The index indicated by xx must be smaller than the value specified in the TableEntries entry. A
color assignment table is always generated with TableEntries entries. lacadcolor must be
smaller or equal to hacadcolor, and they must be in the range between 0 and 255.
Overlapping ranges should be avoided. The DMF color numbers supported are shown on page
D-98, Appendix - Color Tables.
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D 9.6 Exit the graphic editor

→Display → Exit...,
→Exit the graphic editor and call up the project tree.

or

→Back!
→Exit the graphic editor and return to the previous menu.

or

→ALT + F4

On quitting a graphic the query ”Save graphic display?” appears.

YES Graphic is saved.
NO Graphic is not saved.
RETURN Remain in the graphic.

D 9.7 Copy, rename and delete graphic displays

Naming, renaming and copying a free graphic must be carried out in the project tree.
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D 10 Appendix - Color Tables

The following tables list the colors available for graphic displays.

As of Version V3 the color tables have three entries for each color:
1. Sequence number = display rank in the graphic editor,
2. Internal color number, used, for example, when converting AutoCAD files into files for the

graphic editor,
3. Designator (name) used for the color in the graphic editor.

Up to and including Version V2 the color table sequence numbers are identical with the
internal color numbers. As a result, there are only two entries for each color:
1. Sequence number = display rank in the graphic editor = internal color number,
2. Designator (name) used for the color in the graphic editor.
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Colors for Version 3; Color table standard.

Static colors
1 0 White
2 12 Grey93
3 13 Grey80
4 14 Grey68
5 16 Grey58
6 15 Grey48
7 17 Grey35
8 7 Black
9 8 Lightblue
10 9 Mediumblue
11 10 Blue
12 11 DarkBlue
13 18 LightMagenta
14 19 MediumMagenta
15 20 Magenta
16 21 DarkMagenta
17 4 LightGreen
18 5 MediumGreen
19 72 Green
20 6 DarkGreen
21 28 LightYellow
22 29 Yellow
23 30 MediumYellow
24 31 DarkYellow
25 1 LemonChiffon1
26 2 LemonChiffon2
27 73 LemonChiffon3
28 3 LemonChiffon4
29 22 MistyRose1
30 74 MistyRose2
31 23 MistyRose3
32 24 MistyRose4
33 76 LightPink
34 80 Pink
35 77 MediumPink
36 78 DarkPink
37 25 LightPurple
38 75 MediumPurple
39 26 Purple
40 27 DarkPurple

Message colors
41 36 RGB1(PrioS1-3)
42 32 RGB2(Prio1)
43 33 RGB3(Prio2)
44 34 RGB4(Prio3/4)
45 35 RGB5
46 37 RGB6
47 38 RGB7
48 39 RGB8
Signal colors

49 64 SigBlue
50 65 SigCyan
51 67 SigRed
52 68 SigGreen
53 69 SigDarkGreen
54 70 SigYellow
55 79 SigOrange
56 190 SigMagenta
57 66 SigBrown
Media colors

58 44 Flash1(PrioS1-3)
59 40 Flash2(Prio1)
60 41 Flash3(Prio2)
61 235 RGB3(Prio2alt.)
62 42 Flash4(Prio3/4)
63 236 RGB4(Prio3alt.)
64 43 Flash5
65..67 45..47 Flash6..Flash8
68..76 120..128 Flash9..Flash17
77..84 182..189 Flash18..Flash25
85 71 Flash26
Free colors

86..104 144..162 Grey1..Grey19
105..123 163..181 Blue1..Blue19
124..139 48..63 Cyan1..Cyan16
140..142 232..234 Cyan17..Cyan19
143..161 100..118 Magenta1..Magenta19
162..180 81..99 Green1..Green19
181 119 Yellow1
182..196 129..143 Yellow2..Yellow16
197..199 191..193 Yellow17..Yellow19
200..218 213..231 Brown1..Brown19
219..237 194..212 Red1..Red19
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Colors for Version 2; Color table compatible.
Sequential number = internal color number

Static colors

1 White
2 LemonChiffon1
3 LemonChiffon2
4 LemonChiffon3
5 LightGreen
6 MediumGreen
7 DarkGreen
8 Black
9 LightBlue
10 MediumBlue
11 Blue
12 DarkBlue
13 Grey93
14 Grey80
15 Grey68
16 Grey48
17 Grey58
18 Grey35
19 LightMagenta
20 MediumMagenta
21 Magenta
22 DarkMagenta
23 MistyRose1
24 MistyRose2
25 MistyRose3
26 LightPurple
27 Purple
28 DarkPurple
29 LightYellow
30 Yellow
31 MediumYellow
32 DarkYellow
Free colors

145..193 Free_1...Free_49

Message colors

33 Prio1_Freq_1
34 Prio2_Freq_1
35 Prio3_Freq_1
36 Prio4_Freq_1
37 Prio5_Freq_1
38 Prio6_Freq_1
39 Prio7_Freq_1
40 Prio8_Freq_1
41..48 Prio1..Prio8_Freq_2
49..56 Prio1..Prio8_Freq_3
57..64 Prio1..Prio8_Freq_4
Signal colors

65 SigBlue
66 SigCyan
67 SigBrown
68 SigRed
69 SigGreen
70 SigDarkGreen
71 SigYellow
72 SigYellow_4Hz
Media colors

73 Med.col 1_0 (Yellowgreen)
74 Med.col 2_0 (FieryRed)
75 Med.col 3_0 (SilverGrey)
76 Med.col 4_0 (Orange cadmium)
77 Med.col 5_0 (Pastel orange)
78 Med.col 6_0 (Red violet)
79 Med.col 7_0 (Ochre brown)
80 Med.col 8_0 (Sky Blue)
81 Med.col 9_0 (Deep black)
82...96 Med.col10_0...23_0
97...120 Med.col 1_2...23_2
121..144 Med.col 1_3...23_4
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D 11 Appendix - Graphic Macro Library

After installation of DigiTool this library is found at: <freelance>/macros/hb_sym01.bol
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E 1 General Description - Logs

Logs are used for logging information and messages from the process and from the Freelance
2000 system. Logs are output on a printer or screen. A distinction is made between two different
types of log - event logs and state logs.

E 1.1 Event logs

Event logs are used for logging events such as messages, faults, switching activities and
operator interventions (incl. user names, if DigiLock installed). Logging is effected spon-
taneously when an event occurs.

The signal sequence log is used for acquisition of events and is therefore classified with the
event logs. A further distinction is made between signal sequence log 1 and signal sequence
log N. Data of signal sequence log 1 are output continuously on a printer. By contrast, data of the
signal sequence log N are output only on completion of logging or per manual intervention.

Various different types of messages can be logged: process messages and system messages
are generally used to indicate events and faults, while a sequence of event log can be used to log
switching events in the field with a resolution of 2 ms.

E 1.2 State logs

State logs are used for cyclic logging of process states. These include the cyclic acquisition of
the state of a tag or the logging of sequences within the process.

The disturbance course log and operation log are classified as state logs. The disturbance
course log uses a special disturbance course log acquisition module from the process station.
The module acquisitions cyclically the input signals and saves them in a ring buffer of max. 200
values per input signal.
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E 1.3 Logs in an operator station

A maximum of four operation logs, four disturbance course logs, one signal sequence log 1
and three signal sequence logs N can be set up for each operator station. (The display and op-
eration of the logs on an operator station is described in the manual DigiVis Operation and Ob-
servation).

The various logs are all programs in the operator station resource of the project tree. Logs can be
set up, deleted, moved and copied in the project tree.

E 1.4 Squence of events

In certain applications there is a requirement to log selected binary signals with a time stamp in
correct chronological order.

In order to achieve this end, the 'Time stamp' function must first be activated in a DDI 01 module
(see Engineering Manual, System Configuration, Hardware Structure). When this function is
activated, an extra binary value and time value for each channel are made available at the output
of this hardware block in addition to the 'standard' 32 binary outputs. When there is an edge
change of the binary value on these outputs, the current value and the associated time (resolution
= update cycle of the module) are stored for each channel.

In an FBD program a function block ‘Sequence of events monitoring M_SOE’ must be configured
(see Engineering Reference Manual, Functions and Function Blocks, Monitoring Function
Blocks). This block can be used to transfer binary values with time stamp of a DDI 01 to a signal
sequence log. In addition, during parameterization a DDI 01 block is assigned to this block, and
the channels to be monitored are defined.

With each cycle of the user task the binary values and time stamps of the DDI 01 block are read.
When the stored binary values are read and time-stamped, the timestamp function in the DDI 01
module is re-activated, i.e. the next edge change of this binary value can be detected and stored.
For each change of value of a monitored channel that is detected in the M_SOE function block, a
message is generated using the binary value and the associated time stamp; this signal can then
be processed further in the signal sequence logs.

These messages are not displayed in the DigiVis message line or message list .
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E 2 Signal Sequence Log Configuration

In the project tree → Select signal sequence log → Double-click left mouse button

The definition of parameters for signal sequence log 1 or signal sequence log N is virtually identi-
cal; they are therefore described together. Where differences do arise, these are shown sepa-
rately.

E 2.1 General data tab - Signal sequence log 1 and N

General data
Name The name of the signal sequence log. The name has been fixed in the proj-

ect tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 charac-
ters can be entered.

di1319uk.bmp
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Long text A Long text can be assigned to the signal sequence log. Up to 30 charac-
ters can be entered.

The short and long texts are output with the project documentation. In addi-
tion these texts can be configured for the header and footer of the
printed log.

Start/Stop
Automatic Logging is automatically started by starting DigiVis.

Event controlled Logging is started and stopped by an event.

Tag name of event
function block Name of event starting logging, Engineering Reference Manual, Functi-

ons and Function Blocks, Monitoring Function Blocks. Press the func-
tion key F2 to bring up a selection list.

Manual The operator can start and stop logging on the operator station. This refers
only to the log previously selected on the operator station.

Filing
in .. files the number of log files are fixed, which are created on DigiVis PC. The

value must be between 1 and 400.

named the name of the log file, which is filed on DigiVis PC hard disk. You can ac-
cept the suggested name or give another.

With max. runtime
... per file The recording period per log file can be defined with this field. Entries are

made in the IEC 1131-3 format. The value range is between 0 and 2147483
sec.

Example:
T#2147483s or T#24d20h31m23s

but not more than
... events The value must be between 3 and 32767. Default 1000 events.

Disk space
requirements
for this log: The size which log files can attain is displayed in this field. This amount of

storage should be available on DigiVis PC.
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E 2.2 Log files tab - Signal sequence log 1 and N

Print
manual The printing of logs can be activated manually by the operator at the op-

erator station.

Print to
Channel 1 / 2 Two printer channels are available for log output on the printer. The printer

channel is selected by activating the corresponding option button.

Delete log files
automatic When the automatic delete option is selected and the configured number of

files is exceeded, the oldest log file is overwritten by the current file.

If the automatic delete option is not selected then logging is suspended
as soon as the max. number of files has been reached.

Manual The operator can select and delete individual log files.

di1321uk.bmp
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Record event from
local resource D-OS Events on the operator station are logged. These include events such as

switching operations and operator actions.

Filter Activates logging of events such as messages and faults on the corre-
sponding resource.

Connection Indicator showing that a connection is configured to the corresponding
operator station.

Filter Either all configured stations or only connected stations are included in the
events selection list.

Areas Messages from the selected areas are set in the signal sequence log.

Type of messages Configures which messages are to be recorded in the log: process mes-
sages, system messages and sequence of events.

E 2.2.1 Enhancements to parameter definition mask 2 in signal sequence log N

Unlike signal sequence log 1, data of signal sequence log N are not printed continuously.
Hence the parameter definition mask 2 differs in the following points:

The following virtual keys are to choose additionally:

Print
Automatic Printing takes place automatically after completing the logging.

Delete log files
Printed files only Only printed log files can be deleted manually.

di1393uk.bmp
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E 2.3 Format tab - Signal sequence log 1 and N

Logging format
Active going
Inactive going The logging format for incoming and outgoing messages can be assigned

to priority levels S1 to 5. Here one can select between Empty, Value, Long
text and all.

Operat.: If operator interventions should be logged, a format other than Empty must
be provided at Operat.

If the optional program DigiLock is installed on the operator station,
the logged user name at this particular time will also listed during the
logging of every operator intervention.

Logging format of acknowledge from
Message line / list Like above format without coming intervention messages (message line

and message list) and messages of priority level 5 (message list), but only
refers to acknowledge in message line and message list.

di1320uk.bmp
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Page layout Defines page layout for the printout. The Lines per page must be entered,
and is between 10 and 100 lines. The number of characters per lines can
be defined as 80 or 132 characters according to the paper format.

HEADER / FOOTER The contents of the log header and footer are freely definable. They can
include static text as well as dynamic process variables. There is also a
collection of globally preset variables. The default is a commonly used form
of the layout. See description on page E-27.

Changes in the header and footer lines generally lead to a change in
size of the log. When the log is downloaded to DigiVis the file size is
checked. A log whose file sizes have changed is treated as a new log.
All existing log files are renamed, and therefore no longer displayed in
DigiVis. The files may be viewed using the archive browser.

E 2.4 File transfer tab - Signal sequence log 1 and N

Defining parameters for the signal sequence log through parameter definition mask 4 includes
copying the stored logs to other data carriers, primarily external devices, for data protection and
archiving purposes.

File transfer
di1946uk.bmp
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Specifies whether and how a copy of the log file is to be transferred from the DigiVis PC to an-
other PC. The PC selected to receive the archive must have a network communication link to the
DigiVis PC. Furthermore, on target stations with Windows NT operating system, the ‘Microsoft
Peer Web Services’ with FTP service must be installed. These services are included in the NT
delivery package. Once installed, they start up independently on login to NT.
Archives are normally sent direct to the target station with its own station address. A further pos-
sibility is to export the archive files to a Windows drive on the DigiVis PC. This drive can be
mapped on to another PC in the Windows NT network. In this case the station address is its own
TCP-IP address.

An add-on Freelance 2000 program called DigiBrowse is provided to allow the archiving PC to
display the log archives and convert them to CSV format.

Automatic
file transfer The mode of file transfer enabling or disabling is specified.

Enable/disable
Enable FT with
DigiVis start As soon as DigiVis is started, file transfer is enabled.

File transfer is not automatically enabled when DigiVis is started.

Event controlled File transfer is enabled or disabled depending on the status of the event
module entered. It is mandatory to specify an event module.

Press the function key F2 to bring up a selection list with event func-
tion blocks.

File transfer cannot be enabled in event-controlled mode.

Manual controlled The operator at the operator station can enable or disable file transfer.
File transfer cannot be enabled or disabled manually.

Trigger This area in the parameter mask is used for specifying how file transfer is to
be triggered.

After file
completion This mode is the default setting for the signal sequence log.

Cyclic, Cycle time This time parameter is used to specify the cyclical time interval between
copies of the log file being written to the specified target station. Entered
in time format (e.g. T#10h).
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Manual FT The operator at the operator station can start the file transfer at any time
by pressing the FILE TRANS. button.
File transfer cannot be started spontaneously. The FILE TRANS button in
the signal sequence log operating dialog is shown grayed out, i.e. it
cannot be selected.

Target The target for the data to be transferred should be specified here. Ideally
the target station will also have the DigiBrowse software installed on it, so
that the trend and log archive files can be displayed and further processed.

Station IP address of the target computer. If the DigiVis PC is to be used as the tar-
get for export, its own IP address must be entered here.

Path If the archive files are to be copied to a directory, the complete directory
name must be entered here. A default path can be set in the target station’s
Peer Web Services, so that only a backslash (\) is entered at this point,
possibly followed by the rest of the path branch. For example, the path
C:\ARCHIV\STATION\SFP for the target computer can mean that it diverts
all received archives to the preset path C:\ARCHIV, and the incoming ar-
chive contributes the path information \STATION1\SFP.

It should be noted that when transferring data the target computer is
responsible for any additional manipulation of the files. The copied file
is only temporary and is overwritten the next time the corresponding
archive is exported.
The target path to the archive storage must be present and may not
be write-protected.

File The export files are stored with the file name entered under Target Path.
Example: STATION1\SFP\SFP_MANUFACTURE. This file is overwritten in
every export. Path and file name together may have a total length of 100
characters.

Directory [8.3] The export files are transferred in DOS format - e.g. to a PC with WfW op-
erating system and active FTP server. The file name corresponds to the
export date in the format ‘YMMDDHHm.mss’, e.g. 70528162.320 .

The file name contains no information about the archive type. Choose
a suitable path name to ensure it is recognizable afterwards.
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Directory The export files are stored in the directory shown under Target Path with
their original name (from parameter definition mask 1). The export date in
the format ‘.YYMMDDHHmmss’ is also appended to the name (separated
by a period).

Example: SFP MANUFACTURE.970528162320.
Path and file name together may have a total length of 100 characters.

Suffix for incre-
mental / complete In order to distinguish between files containing complete data sets and

those containing incremental data sets, the suffixes '_INC' or '_FULL'
are appended to the basic file names. This extension renders it impos-
sible for files to be lost by overwriting one another.

FTP timeout FTP utilities are synchronous utilities. In order to prevent the system
from becoming congested a maximum time should be entered here
within which a transfer must be completed. If timeout is exceeded, it causes
a system alarm in DigiVis.

User name The user name is made up (NT) of the working group and valid user of the
target station.
The user name must be entered. It will be checked by the target station.

Password The password corresponds to the user password for the target station.
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E 3 Disturbance Course Log Configuration

E 3.1 General tab - Disturbance course log

In the project tree → Select disturbance course log → Double click left mouse button

General data
Name The Name of the signal sequence log. The name has been fixed in the

project tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 charac-
ters can be entered.

Long text A Long text can be assigned to the signal sequence log. Up to 30 charac-
ters can be entered.

The short and long texts are output with the project documentation. In addi-
tion these texts can be configured for the header and footer of the printed
log.

di1323uk.bmp
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Start/Stop
Automatic Logging is automatically started by starting DigiVis.

Event controlled Logging is started and stopped by an event.

Tag name of event
function block Name of event starting logging,

see Engineering Reference Manual, Functions and Function Blocks,
Monitoring Function Blocks.
Press the function key F2 to bring up a selection list.

Manual The operator can start and stop logging on the operator station. This refers
only to the log previously selected on the operator station.

Filing
in .. files the number of log files are fixed, which are created on DigiVis PC. The

value must be between 1 and 400.

named the name of the log file, which is filed on DigiVis PC hard disk. The preset
name can be accepted, or a new one given.

With max. runtime
... per file The recording period per log file can be defined with this field. Entries are

made in the IEC 1131-3 format. The value range is between 0 and 2147483
sec.

Example:
T#2147483s or T#24d20h31m23s

Allocated disturbance
course log function block

Name of the disturbance course log acquisition module on the process sta-
tion, see Engineering Reference Manual, Functions and Function
Blocks, Acquisition Blocks. Press the function key F2 to bring up a se-
lection list.

Disk space
requirements
for this log: The size which log files can attain is displayed in this field. This requirement

should be available on DigiVis PC.
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E 3.2 Log files tab - Disturbance course log

Delete log files
automatic When the automatic delete option is selected and the configured number of

files is exceeded, the oldest log file is overwritten by the current file.

If the automatic delete option is not selected then logging is suspended
as soon as the max. number of files has been reached.

Manual The operator can select and delete individual log files.

Printed files only Only printed log files can be deleted manually.

Page layout Defines page layout for the printout. The number of Lines per page must be
entered and is between 10 and 100 lines. The number of characters per
line can be defined as 80 or 132 characters according to the paper format.

HEADER / FOOTER The contents of the log header and footer are freely definable. They can
include static text and dynamic process variables. There is also a collection
of globally preset variables. The default is a commonly used form of the
layout. See description on page E-27.
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Print to
Channel 1 / 2 Two printer channels are available for log output on the printer. The printer

channel is selected by activating the corresponding option button.

Printing
Manual Print of the disturbance course log can be activated by the operator at the

operator station.

Automatic Printing takes place automatically after completing the logging.

E 3.3 Variables description tab - Disturbance course log

di1324uk.bmp
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Parameters trigger
The time of acquisition of the variables to be parameterized is based on the configured signal
situation on the disturbance course log acquisition module.
See Engineering Reference Manual, Functions and Function Blocks, Acquisition Blocks.

Trig.:
Name Name of the variable that triggers the switch on the disturbance course log

acquisition module. This name appears for information only and is included
in the printout. It is not evaluated further as the acquisition modules trig in-
put bears this responsibility. Even if the trigger is not actuated by a variable,
a text must be entered here.

Text Text that will be output as a comment after the name of the trigger variable.

Parameters variable specification
Up to six variables can be configured for data acquisition for the disturbance course log. The
number of variables is limited by the inputs in the disturbance course acquisition module.

V1 ... V6
Name Name of the variable on the process station.

Text Text output on logging the variable.

Format The format is necessary for output of variables in the log. See Engineering
Manual, Operator Station, Grafic Display, Alphanumeric Display, Se-
lect and create own formats.

Dimension The dimension assigned to the variable. The dimension is output with the
variable value during logging.

No plausibility check is performed on name, text or dimension as the variables are config-
ured permanently with the acquisition module. Details included here serve only to provide
information and are included in the log when it is printed out.

E 3.4 File transfer tab - Disturbance course log

This parameter definition mask corresponds to the parameter definition mask of the Signal
Sequence Log, see page E-12.

Gross Automation, 1725 South Johnson Road, New Berlin, WI 53146, www.ssacsales.com, 800-349-5827



Section E Logs

E-21

E 4 Operation Log Configuration

E 4.1 General tab - Operation log

In the project tree → Select operation log → Double click left mouse button

General data
Name The name of the signal sequence log. The name has been fixed in the proj-

ect tree and cannot be changed here.

Short text A Short text can be assigned to the signal sequence log. Up to 12 charac-
ters can be entered.

Long text A Long text can be assigned to the signal sequence log. Up to 30 charac-
ters can be entered.

The short and long texts can be output with the project documentation.
These texts can also be configured for the header and footer of the
printed log.

TEXT... Configuration operation log text, see page E-23.
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Start/Stop
Automatic Logging is automatically started by starting DigiVis.

Event controlled Logging is started and stopped by an event.

Tag name of event
function block Name of event starting logging,

see Engineering Reference Manual, Functions and Function Blocks,
Monitoring Function Blocks.
Press the function key F2 to bring up a selection list.

Manual The operator can start and stop logging on the operator station. This refers
only to the log previously selected on the operator station.

Filing
in .. files specifies the number of log files, which are created on DigiVis PC. The

value must be between 1 and 400.

named the name of the log file, which is filed on DigiVis PC hard disk. The preset
name can be accepted, or a new one given.

Number of cycles With the start of logging, the data is written cyclically to the file according to
the entered cycle time. The range of values lies between 1 and 32767.

Cycle time This field specifies the interval between two recordings. Entries are made in
the IEC 1131-3 format. The value range is between 0 and 2147483 sec.

Example:
T#2147483s or T#24d20h31m23s.

The recording time in a file is calculated from the number of cycles x
cycle time.

Disk space req.
for this log: The size which log files can attain is displayed in this field. This requirement

should be available on DigiVis PC.
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E 4.2 Text layout on parameter definition mask - Operation log

In the project tree → Select operation log → Double click left mouse button → TEXT

Parameter definition mask Text comprises a text field and an operator line. In the text field, any
text can be mixed with the formatted output of variables in the operation log. Up to 200 variables
are permitted per operation log. The number of lines and columns are defined by the page layout
in the parameter definition mask 2.
Using the conventional windows mouse and key commands, text can be marked, cut, copied and
inserted within the text field.

CHECK One can test whether errors have been made during text entry or dynami-
zation.

Each dynamic entry must consist of a variable and a display format.
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DYNAMIC During DYNAMIC a variable is selected, and its current value should be re-
corded in the log. Dynamic entries are shown in square brackets.

DYNAMIC → Select variable → OK

To retrospectively assign a different value to a format, position the
cursor between the square brackets and push DYNAMIC.

FORMAT A variable is assigned to a display format, e.g. the number of digits after
decimal will be defined.

FORMAT → select format → OK

To assign later an other format to a variable, take position between
the square brackets and push FORMAT.

PRINT PREVIEW The forthcoming PRINT PREVIEW of the operation log is displayed. Only the
format specification and text are still visible in the print preview. The square
brackets and the variable names are not displayed.

Variable names cannot be changed in the print preview display.

Back to the parameter mask for inputs → EDIT

PRINT AS TABLE The operation log is printed out in tabular form. This means that the part
with the dynamic area is repeated, indeed it is repeated as many times
as the page layout allows
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E 4.3 Printing tab - Operation log

Print to
Channel 1 / 2 Two printer channels are available for log output on the printer. The printer

channel is selected by activating the corresponding option button.

Print
Manual Print of the signal sequence log can be activated by the operator at the op-

erator station.
Automatic Printing takes place automatically after completing the logging.

Delete log files
Automatic When the automatic delete option is selected and the configured number of

files is exceeded, the oldest log file is overwritten by the current file.

If the automatic delete option is not selected then logging is stopped as
soon as the max. number of files has been reached.

Manual The operator can select and delete individual log files.

Printed files only Only printed log files can be deleted manually.
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Page layout Defines page layout for the printout. The number of Lines per page must be
entered and is between 10 and 100 lines. The number of characters per
line can be defined as 80 or 132 characters.

HEADER / FOOTER The contents of the log header and footer are freely definable. They can
include static text and dynamic process variables. There is also a collection
of globally preset variables. The default is a commonly used form of the
layout. See description on page E-27.

E 4.4 File transfer tab - Operation log

This parameter definition mask corresponds to the parameter definition mask of the Signal
Sequence Log, see page E-12.
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E 5 Header and Footer Lines in Logs

The following elements can be incorporated in text for headers and footers:
• Static text that appears unchanged in the header and footer line on each page
• Field references, referring to the DigiTool documentation
• Variables.

Global variables
Project-specific fields (expanded from the project description into static text during the plausibility
check):

$PrjComm Project comment
$PrjDate Date of the project, the format "dd.mm.yy" (length: 8 characters) must be

specified
$PrjMan Manager of current project
$PrjName Name of project (length: 8 characters)
$PrjNr Project number
$PrjOrd Project order
$PrjOrdNr Order number of project
$ProtType Log type
$ProtST Short text of log
$ProtLT Long text of log
$ProtName Name of log

Dynamic fields (expanded into static text at run time of the log file):

$ProtStart Start time of log file
$ProtStop Stop time of log file

Dynamic fields (expanded into static text when log file is printed out):

$PgNr Page number (max. length: 3 characters)
$PrintDate Time of printing, consisting of the date and time
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Variables
The variables are selected in the same way as when the text of the log becomes dynamic, i.e. a
variable and its output format are specified [format|VarName]. When a log file is started under
DigiVis, the configured variables are read once, converted to the format specified and then en-
tered into the header or footer line.

In the project tree → Select log → HEADER or FOOTER button.

VARIABLE Selects a variable (from a list)

FORMAT Assigns a format (from a list)

FIELD Selects a field (from a list)

tv001us.bmp
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